1001:Exponentiation

描述

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of Rnwhere R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 

输入
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
输出

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.


样例输入
95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12
样例输出
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


#include "stdio.h"
#include "string.h"
#include "stdlib.h"
#include "math.h"
#define MAX 200


char str1[MAX];
char a1[MAX];
char a2[MAX];
char r1[MAX];
char r2[MAX];


int ca;
int len1;
int len2;
int t1;
int n;




int main(){


while (1){
int flag = 1;
int dot = 0;
if (scanf("%s", str1) == EOF)
{
break;
}
double dou = atof(str1);


len1 = strlen(str1) - 1;
len2 = len1;
for (int s = 0, d = len1; d >= 0; s++, d--)
{
if (str1[d] == '.')
{
dot = s;
s--;
}
else{
a1[s] = str1[d];
a2[s] = str1[d];
}
}


int ip = 0;
for (int i = len1 - dot - 1, w = 0; i >= 0; i--, w++)
{
ip += (str1[i] - '0') * pow(10.0, w);
}


if (dou - ip < 0.0000001)
{
flag = 0;
}


scanf("%d", &n);


for (int i = 0; i < MAX; i++)
{
r1[i] = '0';
}




for (int f = 1; f < n; f++)
{
for (int i = 0; i < len2; i++)
{
ca = 0;
for (int k = 0; k < MAX; k++)
{
r2[k] = '0';
}
int j;
for (j = 0; j < len1; j++)
{
t1 = (a2[i] - '0') * (a1[j] - '0') + ca;
ca = t1 / 10;
r2[j + i] = t1 - ca * 10 + '0';
}
r2[j + i] = ca + '0';


ca = 0;
for (j = 0; j < MAX; j++)
{
t1 = r1[j] - '0' + r2[j] - '0' + ca;
if (t1 < 10)
{
r1[j] = t1 + '0';
ca = 0;
}
else{
r1[j] = t1 - 10 + '0';
ca = 1;
}
}
}


len1 = 0;
for (int i = 0; i < MAX; i++)
{
if (r1[i] != '0')
{
len1 = i + 1;
}
a1[i] = r1[i];
r1[i] = '0';
}
}


int end = 0;
for (int i = 0; i < len1; i++)
{
if (a1[i] != '0')
{
end = i;
break;
}
}

dot = dot * n;
if (len1 < dot)
{
len1 = dot;
}
for (int i = len1 - 1; i >= dot; i--)
{
printf("%c", a1[i]);
}
if (flag){
printf(".");
for (int i = dot - 1; i >= end; i--)
{
printf("%c", a1[i]);
}
}
printf("\n");
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值