【矩阵快速幂】 hdu1757 A Simple Math Problem

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4384    Accepted Submission(s): 2630


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .
Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 
Output
For each case, output f(k) % m in one line.
Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0

Sample Output
  
  
45 104
 
代码:
#include<stdio.h>  
#include<string.h>  
#define N 10  
typedef long long LL;  
  
LL mod;  
struct Matrix  
{  
    LL mat[N][N];  
    Matrix()
    {
        memset(mat,0,sizeof(mat));
    }
};  
  
Matrix mul(Matrix a, Matrix b) //矩阵相乘  
{  
    Matrix res;  
    for(int i = 0; i < N; i++)  
        for(int j = 0; j < N; j++)  
        {  
            for(int k = 0; k < N; k++)  
            {  
                res.mat[i][j] += a.mat[i][k] * b.mat[k][j];  
                res.mat[i][j] %= mod;  
            }  
        }  
    return res;  
}  
  
Matrix pow_matrix(Matrix a, LL n)  //矩阵快速幂  
{  
    Matrix res ;  


    for(int i=0; i<N; i++)  
        res.mat[i][i]=1;  
    while(n != 0)  
    {  
        if(n & 1)  
            res = mul(res, a);  
        a = mul(a, a);  
        n >>= 1;  
    }  
    return res;  
}  
  
int main()  
{  
     
    LL k;  
    while(scanf("%lld%lld",&k,&mod)!=EOF)  
    {  
        Matrix A,B;
        LL f[N];  
        for(int i=0; i<N; i++)  
            scanf("%lld",&f[i]);  
  
        if(k<10)  
            printf("%lld\n",f[k]%mod);  
        else  
        {  
            for(int i=0; i<N; i++)  A.mat[i][0]=9-i;
            for(int i=0; i<N; i++)  B.mat[0][i]=f[i];
            for(int i=1; i<N; i++)  B.mat[i][i-1]=1;
  
            B= pow_matrix(B, k-9);  
            A = mul(B, A);  


            printf("%lld\n",(A.mat[0][0] + mod) % mod);  
        }  
    }  
    return 0;  
}  

模板来自;


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值