A Simple Math Problem

A Simple Math Problem

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 24   Accepted Submission(s) : 16
Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 

Author
linle
 

Source
2007省赛集训队练习赛(6)_linle专场
 
#include<stdio.h>
#include<string.h>

int A[10][10], B[10][10], M;
void mul(int X[10][10], int Y[10][10])
{
	int Z[10][10];
	int i, j, k;
	memset(Z, 0, sizeof(Z));
	for (i = 0; i < 10; i++)
		for (j = 0; j < 10; j++)
			for (k = 0; k < 10; k++)
				Z[i][j] = (Z[i][j] + X[i][k] * Y[k][j] % M) % M;
	memcpy(X, Z, sizeof(Z));
}
int f(int n)
{
	int i;
	if (0<=n&&n<=9	)
		return n;
	n-=9;
	memset(B, 0, sizeof(B));
	for (i = 0; i < 10; i++)
		B[i][i] = 1;
	while (n)
	{
		if (n & 1)	mul(B, A);
		mul(A, A);
		n >>= 1;
	}
	return B[0][0] * 9 + B[0][1] * 8 + B[0][2] * 7 + B[0][3] * 6 + B[0][4] * 5 + B[0][5] * 4 + B[0][6] * 3 + B[0][7] * 2 + B[0][8] * 1 + B[0][9] * 0;
}

int main()
{
	int i, k, b, n, sum,j;
	while (scanf("%d%d", &k, &M) != EOF)
	{
		for (i = 0; i < 10;i++)
		scanf("%d", &A[0][i]);
		for (i = 1; i < 10; i++)
			for (j = 0; j < 10; j++)
			{
				if (j == i - 1)
					A[i][j] = 1;
				else
					A[i][j] = 0;
			}
		printf("%d\n", f(k)%M);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值