HDU - 1757 - A Simple Math Problem ( 矩阵快速幂 )

Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104


思路:和UVa的1087是一样的  题目链接


#include<cstdio>
#include<cstring>
#define LL long long
using namespace std;
int n,k,m;

struct Matrix{
	LL m[10][10];
	Matrix(){memset(m,0,sizeof(m));}
};

Matrix Mul(Matrix x ,Matrix y){
	Matrix ans;
	for(int i=0 ;i<10 ;i++){
		for(int j=0 ;j<10 ;j++){
			for(int k=0 ;k<10 ;k++){
				ans.m[i][j] = ( ans.m[i][j] +  x.m[i][k] * y.m[k][j] )%m;
			}
		}
	}
	return ans;
}

Matrix q_pow(Matrix x,int k){
	Matrix ans;
	for(int i=0 ;i<10 ;i++) ans.m[i][i]=1;

	while(k){
		if(k&1) ans = Mul(ans,x);
		x = Mul(x,x);
		k >>= 1;
	}
	return ans;
}

int main(){
	LL a0,a1,a2,a3,a4,a5,a6,a7,a8,a9;
	while(scanf("%d%d",&k,&m)!=EOF){
		scanf("%lld%lld%lld%lld%lld%lld%lld%lld%lld%lld",&a0,&a1,&a2,&a3,&a4,&a5,&a6,&a7,&a8,&a9);
		if(k<10){
			printf("%d\n",k);
		}else{
			Matrix T ;
			T.m[0][0] = a0;T.m[0][1] = a1;T.m[0][2] = a2;T.m[0][3] = a3;T.m[0][4] = a4;
			T.m[0][5] = a5;T.m[0][6] = a6;T.m[0][7] = a7;T.m[0][8] = a8;T.m[0][9] = a9;
		
			for(int i=1 ;i<10 ;i++) T.m[i][i-1]=1;
		
			Matrix ans = q_pow(T,k-9);
			LL res = 0;
			for(int i=0 ;i<10 ;i++){
				res = (res+ans.m[0][i]*(9-i))%m;
			}
			printf("%lld\n",res);
		}	
	}
	return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值