hdu 5014 Number Sequence

Number Sequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2533    Accepted Submission(s): 1020
Special Judge


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● a i ∈ [0,n] 
● a i ≠ a j( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a 0 ⊕ b 0) + (a 1 ⊕ b 1) +···+ (a n ⊕ b n)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 10 5), The second line contains a 0,a 1,a 2,...,a n.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b 0,b 1,b 2,...,b n. There is exactly one space between b i and b i+1 (0 ≤ i ≤ n - 1). Don’t ouput any spaces after b n.
 

Sample Input
  
  
4 2 0 1 4 3
 

Sample Output
  
  
20 1 0 2 3 4
 

Source

 这道题是学弟的思路;

题意:
给定一个n,输入0-n区间各数字,各不相同;输出也是0-n区间各个数字;
要求你的对应输出的数串要与原数串的对应异或和最大;

思路:从n-0开始向前找所对应的值,最佳对应的就是i^j=i+j
                           例如n==10,          二进制为1 0 1 0
                    那么它所最佳对应的二进制为0 1 0 1;
            每次找到对应标记一下;复杂度为o(nlongn);

代码:

   
   
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<stack>
#include<cmath>
using namespace std;
typedef long long ll;
typedef pair<int,int> P;
const int inf=1e9-1;
const int maxn=100005;

int a[maxn],b[maxn];
int c[35];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        ll sum=0;
        memset(b,-1,sizeof(b));

        for(int i=0; i<=n; i++)
            scanf("%d",&a[i]);
        for(int i=n; i>=0; i--)
        {
            if(b[i]==-1)
            {
                int num=i,k=0;
                while(num)
                {
                    c[k++]=num%2;
                    num/=2;
                }

                int ans=0,m=1;
                for(int j=0; j<k; j++)
                {
                    if(c[j]==0)
                        ans+=m;
                    m*=2;
                }
                b[ans]=i;
                b[i]=ans;
                sum+=(ans+i)*2;
            }
        }
        printf("%I64d\n",sum);
        for(int i=0;i<=n;i++)
        {
            printf("%d",b[a[i]]);
            if(i!=n)
                printf(" ");
        }
        printf("\n");
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值