poj1724 ROADS

ROADS
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14863 Accepted: 5393

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find  the shortest path from the city 1 to the city N  that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11


题意:给定点数,边数,钱数,边上有两个权值,长度、过路费;要求总过路费不超过钱数的情况下的最短路;

思路:假装是最短路的爆搜,也是可以用dijk+优先队列的方法;使用广搜+优先队列(优先短路和少钱数);

另外学习这道题的时候也了解到了优先队列定义优先级的方法:链接;


代码:

#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
const int maxn=110;

int K,N,R,ans;

struct node   //邻接表的结点;
{
    int d,l,t;
    friend bool operator < (node a,node b)  //定义优先队列优先级;
    {
        if(a.l!=b.l)
            return a.l>b.l;
        else if(a.t!=b.t)
            return a.t>b.t;
    }
};
vector<node>G[maxn];  //邻接表;

void bfs()
{
    priority_queue<node>que;
    while(!que.empty())  que.pop();
    que.push(node{1,0,0});

    while(que.size())
    {
        node u=que.top();
        que.pop();

        if(u.d==N)
        {
            ans=u.l;break;
        }

        for(int i=0;i<G[u.d].size();i++)
        {
            if(u.t+G[u.d][i].t<=K)
            {
                node tt;
                tt.d=G[u.d][i].d;
                tt.l=u.l+G[u.d][i].l;
                tt.t=u.t+G[u.d][i].t;
                que.push(tt);
            }
        }
    }
    printf("%d\n",ans);
}

int main()
{
    scanf("%d%d%d",&K,&N,&R);
    for(int i=0;i<R;i++)
    {
        int s,d,l,t;
        scanf("%d%d%d%d",&s,&d,&l,&t);
        G[s].push_back((node){d,l,t});
//        G[d].push_back((node){s,l,t});
    }
    ans=-1;
    bfs();
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值