hdu 5974 A Simple Math Problem

A Simple Math Problem

Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
Sample Input
6 8
798 10780
Sample Output
No Solution
308 490
Source

2016ACM/ICPC亚洲区大连站-重现赛(感谢大连海事大学)


题意:给定a,b,找到一组数据x,y使得 x+y=a,lcm(x,y)=b;

思路:学弟猜测:gcd(x,y)=gcd(a,b);


严格证明(转自:点我啊):

已知条件:

①x+y=a,

②lcm(x,y)=b.

令gcd(x,y)=g;

则 x/g=k1 ,y/g=k2 且 k1与k2互质 (由于gcd为最大公约数);

==>  g*k1+g*k2=a;

         g*k1*k2=b;

==>  k1+k2=a/g;

         k1*k2=b/g;

因k1与k2互质,所以k1+k2与k1*k2互质;

所以 a/g 与 b/g 也互质!

那么g就是gcd(a,b);

所以gcd(x,y)=gcd(a,b);


代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

int main()
{
    int a,b,c;
    while(scanf("%d%d",&a,&b)!=EOF)
    {
        c=__gcd(a,b);
        int x,y;
        if((a*a-4*b*c)<0)
        {
            printf("No Solution\n");
            continue;
        }
        x=(int)((a+sqrt(a*a-4*b*c))/2);
        y=a-x;

        if(x*y/__gcd(x,y)!=b)
        {
            printf("No Solution\n");
            continue;
        }

        if(x>y)
            swap(x,y);
        printf("%d %d\n",x,y);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值