杭电1051解题报告

题目内容:


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3


解题思路:题目大致意思是加工木棒,第一根加工的木棒耗费一分钟,接下来的每根木棒长度和重量大于或者等于第一根木棒则不费时间,否则需要花费一分钟。找到花费时间最少的最优解,首先将木棒长度按升序排列,若有相等情况则按木棒重量升序排列,安装前将数组赋初值为0,每安装一根初值变为1,若前一根木棍重量大于后一个根木棍,则时间加1。


解题代码:


#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{//定义结构体,方便查找 
int weight;//重量 
int length;//长度 
int valid;//是否安装 
}a[5001];
bool cmp(node a,node b) //将数组长度升序排列,若相等则按照重量升序排列 
{
if(a.length==b.length) return a.weight<b.weight;
else return a.length<b.length;
}
int main (void)
{
int n,m,i,j,k,temp,t;
scanf("%d",&m);
while(m--)
{
t=0;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&a[i].length,&a[i].weight);
a[i].valid=0;//初始化数组为0 
}
sort(a,a+n,cmp);//排序 
for(i=0;i<n;i++)
        {
            if(!a[i].valid)
            {
                temp=i;
                for(j=i+1;j<n;j++)//判断前一根木棍重量和长度是否小于或等于后一根木棍重量和长度 
                {
                    if(a[j].valid==0&&a[temp].length<=a[j].length&&a[temp].weight<=a[j].weight)
                    {
                        a[j].valid=1;
                        temp=j;
                    }
                }
                a[i].valid=1; 
                t++; 
            }
        }
printf("%d\n",t);
   }
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值