PAT Advanced 1099. Build A Binary Search Tree (30)

问题描述:

1099. Build A Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.The right subtree of a node contains only nodes with keys greater than or equal to the node's key.Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42

这一题是在我还没学会dfs算法的时候写的,思路是:将每一个结点的左子树和右子树的大小算出来,再根据每个结点在中序遍历中对应的位置找到它们的值,现在想一想似乎只要用dfs算法就解决了。。。

不过有一点还是值得学习的:在题目要求使用某种固定方式输出时,可以根据这种方式为每个元素定义一个关联值组成pair<>,然后在排序时,根据关联值排序输出。

AC代码:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
#include<bits/stdc++.h>
using namespace std;
struct node
{
	int r;
	int l;
	int cr;
	int cl;
} no;
struct per
{
	int d;
	int v;
	bool operator<(const per& ep) const
	{
		if(d!=ep.d)
		return d<ep.d;
		else
		return v<ep.v;
	}
} p;
vector<node> v;
vector<per> vr;
vector<int> va;
inline int f(int r)
{
	if(v[r].l>0)
	{
		vr[v[r].l].d=vr[r].d+1;
		f(v[r].l);
		v[r].cl=v[v[r].l].cr+v[v[r].l].cl+1;
	}
	else
	v[r].cl=0;
	
	if(v[r].r>0)
	{
		vr[v[r].r].d=vr[r].d+1;
		f(v[r].r);
		v[r].cr=v[v[r].r].cr+v[v[r].r].cl+1;
	}
	else
	v[r].cr=0;
}
inline void fv(int b,int r)
{
	vr[r].v=va[b+v[r].cl];
	if(v[r].cl>0)
	{
		fv(b,v[r].l);
	}
	if(v[r].cr>0)
	{
		fv(b+v[r].cl+1,v[r].r);
	}
}
int main()
{
//	ios::sync_with_stdio(false);
//  	freopen("data.txt","r",stdin);
  	int n,x;
	scanf("%d",&n);
	no.l=-1;
	no.r=-1;
	v.resize(n,no);
	vr.resize(n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&x);
		v[i].l=x;
		scanf("%d",&x);
		v[i].r=x;
	}
	for(;n--;)
	{
		scanf("%d",&x);
		va.push_back(x);
	}
	sort(va.begin(),va.end());
	vr[0].d=0;
	f(0);
	fv(0,0);
	sort(vr.begin(),vr.end());
	printf("%d",vr[0].v);
	for(int i=1;i<vr.size();i++)
	printf(" %d",vr[i].v);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值