1099. Build A Binary Search Tree (30)

102 篇文章 0 订阅
29 篇文章 0 订阅

1099. Build A Binary Search Tree (30)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:
    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    
    Sample Output:
    58 25 82 11 38 67 45 73 42
    有N个结点(0-N-1),接下来N个结点的左结点和右结点标号,无为-1;再接下来给出N个要填充的值;填充要点左<中,中<=右;
    做法先按非降序排列#include<algorithm> 使用
DFS深度优先搜索中序填充  左-中-右
输出一层一层输出用到BFS广度优先搜索 中-左-右
用到了 #include <queue> queue先进先出

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月02日 10:34答案正确301099C++ (g++ 4.7.2)1436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118018/18
1答案正确14363/3
2答案正确11803/3
3答案正确13081/1
4答案正确11805/5

#include<iostream>   
#include<algorithm>
#include<queue>
#define NOEXIST -1
using namespace std;  
struct BinarySearch
{
  int left_index, right_inde;
  int value;
};
void Dureadln(int*data, BinarySearch*SubTree, int N)
{
  int index;
  for (index = 0; index < N; index++)
    cin >> SubTree[index].left_index >> SubTree[index].right_inde;
  while (index--)
    cin >> data[index];
}
bool dataCMp(const int &A,const int&B)
{
  return A < B;
}
void buildSubtreevalueDFS(int*data, BinarySearch*SubTree, int* dataindex,int root)
{
  if (NOEXIST != SubTree[root].left_index)
    buildSubtreevalueDFS(data, SubTree,  dataindex, SubTree[root].left_index);
  SubTree[root].value = data[(*dataindex)++];
  if (NOEXIST != SubTree[root].right_inde)
    buildSubtreevalueDFS(data, SubTree, dataindex, SubTree[root].right_inde);
}
void printfBFS(BinarySearch*SubTree, int root)
{
  queue<int>Qroot;
  int len,newroot;
  cout << SubTree[root].value;
  Qroot.push(root); 
  while (!Qroot.empty())
  {
    len = Qroot.size();
    while (len--)
    {
     
      root = Qroot.front(); 
      if (NOEXIST != SubTree[root].left_index)
      {
        newroot = SubTree[root].left_index; 
        cout <<" "<< SubTree[newroot].value ;
        Qroot.push(newroot);
      }
      if (NOEXIST != SubTree[root].right_inde)
      {
        newroot = SubTree[root].right_inde; 
        cout <<" "<< SubTree[newroot].value ;
        Qroot.push(newroot);
      }
      Qroot.pop();
     }
  }
  cout << endl;
}
int main()
{   
  int*data;
  BinarySearch*SubTree;
  int N;
  int dataindex,root;
  cin >> N;
  data = new int[N];
  SubTree = new BinarySearch[N];
  Dureadln(data,SubTree,  N);
  sort(data, data + N, dataCMp);
  dataindex = 0;
  root = 0;
  buildSubtreevalueDFS(data, SubTree, &dataindex,root);
  printfBFS( SubTree, root);
  delete[]SubTree;
  delete[]data;
  system("pause");
  return 0;
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
【Solution】 To convert a binary search tree into a sorted circular doubly linked list, we can use the following steps: 1. Inorder traversal of the binary search tree to get the elements in sorted order. 2. Create a doubly linked list and add the elements from the inorder traversal to it. 3. Make the list circular by connecting the head and tail nodes. 4. Return the head node of the circular doubly linked list. Here's the Python code for the solution: ``` class Node: def __init__(self, val): self.val = val self.prev = None self.next = None def tree_to_doubly_list(root): if not root: return None stack = [] cur = root head = None prev = None while cur or stack: while cur: stack.append(cur) cur = cur.left cur = stack.pop() if not head: head = cur if prev: prev.right = cur cur.left = prev prev = cur cur = cur.right head.left = prev prev.right = head return head ``` To verify the accuracy of the code, we can use the following test cases: ``` # Test case 1 # Input: [4,2,5,1,3] # Output: # Binary search tree: # 4 # / \ # 2 5 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 <-> 4 <-> 5 # Doubly linked list in reverse order: 5 <-> 4 <-> 3 <-> 2 <-> 1 root = Node(4) root.left = Node(2) root.right = Node(5) root.left.left = Node(1) root.left.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) # Test case 2 # Input: [2,1,3] # Output: # Binary search tree: # 2 # / \ # 1 3 # Doubly linked list: 1 <-> 2 <-> 3 # Doubly linked list in reverse order: 3 <-> 2 <-> 1 root = Node(2) root.left = Node(1) root.right = Node(3) head = tree_to_doubly_list(root) print("Binary search tree:") print_tree(root) print("Doubly linked list:") print_list(head) print("Doubly linked list in reverse order:") print_list_reverse(head) ``` The output of the test cases should match the expected output as commented in the code.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值