PAT Advanced 1133 Splitting A Linked List (25)

问题描述:

1133 Splitting A Linked List (25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

AC代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
//	freopen("data.txt","r",stdin);
	vector<int> vadd(100000,0);
	vector<int> vval(100000,0);
	int n,k,fadd,add,val;
	scanf("%d%d%d",&fadd,&n,&k);
	for(;n--;)
	{
		scanf("%d%d",&add,&val);
		vval[add]=val;
		scanf("%d",&val);
		vadd[add]=val;
	}
	add=fadd;
	int madd=-1,okadd=-1,kpadd=-1;
	n=-1;
	val=-1;
	fadd=-1;
	for(;add!=-1;)
	{
		if(vval[add]<0)
		{
			if(madd!=-1)
			vadd[madd]=add;
			else
			fadd=add;
			madd=add;
			add=vadd[add];
			vadd[madd]=-1;
		}
		else if(vval[add]>=0&&vval[add]<=k)
		{
			if(okadd!=-1)
			vadd[okadd]=add;
			else
			val=add;
			okadd=add;
			add=vadd[add];
			vadd[okadd]=-1;
		}
		else if(vval[add]>k)
		{
			if(kpadd!=-1)
			vadd[kpadd]=add;
			else
			n=add;
			kpadd=add;
			add=vadd[add];
			vadd[kpadd]=-1;
		}
	}
	if(madd==-1&&okadd==-1)
	fadd=n;
	else if(madd==-1)
	fadd=val;
	else if(okadd==-1)
	vadd[madd]=n;
	else
	{
		vadd[madd]=val;
		vadd[okadd]=n;
	}
	add=fadd;
	for(;add!=-1;)
	{
		printf("%05d %d ",add,vval[add]);
		if(vadd[add]!=-1)
		printf("%05d\n",vadd[add]);
		else
		printf("%d\n",vadd[add]);
		add=vadd[add];
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值