PTA (Advanced Level) Practice 1001 C++

1001 A+B Format (20 分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification

Each input file contains one test case.
Each case contains a pair of integers a and b where -106 ≤a,b≤106
The numbers are separated by a space.

Output Specification

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output

-999,991

思路和代码

将计算和之后的数用字符数组储存,判断位数打印“,”。

#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1e6 + 10;
char sum[N];
int a, b;

int main()
{
    cin >> a >> b;
    sprintf(sum, "%d", a + b);
    int len = strlen(sum);
    for(int i = 0; i < len; ++i)
    {
        cout << sum[i];
        if(sum[0] == '-')
		{
			if(i == 0 || i == len - 1) continue;
			else if((len - i) % 3 == 1) cout << ",";
		} 
		else
		{
			if(i == len - 1) continue;
			else if((len - i) % 3 == 1) cout << ",";
		}
    }
    return 0;
}

小结

编程小白刚开始刷题,没有使用太多数据结构(那些我也刚入门,不太熟练,看到用vector, stack等等写的,代码比我长一些,没有细看,因为觉得自己的思路可行,写完blog去学习一下)思路也比较暴力,代码中好多边界值都是debug出来的,凭空想的话确实不太容易一遍对。
请各位大神多多指教~

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值