poj3276

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5121 Accepted: 2374

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N 
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source

 

 

 

ac代码

import java.util.Scanner;

public class Main{

	/**
	 * @param args
	 */
	static int dir[]=new int[5000+2];
	static int n;
	static int f[]=new int[5000+2];
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		n=scan.nextInt();
		scan.nextLine();
		for(int i=0;i<n;i++){
			String str=scan.nextLine();
			if(str.equals("F")){
				dir[i]=0;
			}else{
				dir[i]=1;
			}
		}
		sovle();
	}
	private static void sovle() {
		// TODO Auto-generated method stub
		int M=n,K=1;
		for(int k=1;k<=n;k++){
			int m=calc(k);
			if(m>0&&M>m){
				M=m;
				K=k;
			}
		}
		System.out.println(K+" "+M);
	}
	private static int calc(int k) {
		// TODO Auto-generated method stub
		init();
		int res=0;
		int sum=0;
		for(int i=0;i+k<=n;i++){
			if((dir[i]+sum)%2!=0){
				res++;
				f[i]=1;
			}
			sum+=f[i];
			if(i-k+1>=0){
				sum-=f[i-k+1];
			}
		}
		for(int i=n-k+1;i<n;i++){
			if((dir[i]+sum)%2!=0){
				return -1;
			}
			if(i-k+1>=0){
				sum-=f[i-k+1];
			}
		}
		return res;
	}
	private static void init() {
		// TODO Auto-generated method stub
		for(int i=0;i<n;i++){
			f[i]=0;
		}
	}

}

  

 

转载于:https://www.cnblogs.com/Katerina/p/7137073.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值