POJ3276 Face The Right Way 【尺取法】

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2721 Accepted: 1246

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than Kcows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Line  i+1 contains a single character,  F or  B, indicating whether cow  i is facing forward or backward.

Output

Line 1: Two space-separated integers:  K and  M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For  K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source



/*
** Problem: POJ No.3276
** Running time: 297MS
** Complier: C++
** Author: Changmu
**
** 题意:N头牛排成一列1<=N<=5000。每头牛或者向前或者向后。为了让所有牛都
** 面向前方,农夫每次可以将K头连续的牛转向1<=K<=N,求操作的最少
** 次数M和对应的最小K。
** 
** 题解:由于交换区间翻转顺序对结果没影响,所以从左往右对于需要
** 翻转的牛进行反转,同时记录对该区间其他牛的影响即cal中的sum,
** 对于最后部分无法翻转的区间检查是否有反向牛,若有则方案失败。 
*/

#include <stdio.h>
#include <string.h>

#define maxn 5010

int cow[maxn], N, K, M; // 奶牛们的初始位置,0前1后
int tra[maxn]; // 是否翻转第i头牛,1翻

int cal(int k) { // 翻转顺序从左往右
    int ans = 0, i, sum = 0;
    for(i = 0; i + k <= N; ++i) {
        tra[i] = 0; // initialize
        if((sum + cow[i]) & 1) {
            tra[i] = 1; 
            ++ans;
        }
        sum += tra[i]; // 尺取法
        if(i - k + 1 >= 0)
            sum -= tra[i-k+1];
    }
    // 检查剩下的是否有反向奶牛
    for( ; i < N; ++i)
        if((sum + cow[i]) & 1)
            return -1;
        else if(i - k + 1 >= 0)
            sum -= tra[i-k+1];
    return ans;
}

int main() {
    char ch[2];
    int i, m, k;
    while(scanf("%d", &N) == 1) {
        for(i = 0; i < N; ++i) {
            scanf("%s", ch);
            if(ch[0] == 'B') cow[i] = 1;
            else cow[i] = 0;
        }
        M = N; K = 1;
        for(k = 1; k <= N; ++k) {
            m = cal(k);
            if(m >= 0 && m < M) {
                M = m; K = k;
            }
        }
        printf("%d %d\n", K, M);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值