ZOJ 3714 Java Beans(暴力)

Description

There are N little kids sittingin a circle, each of them are carrying some java beans in their hand. Theirteacher want to select M kids whoseated in M consecutiveseats and collect java beans from them.

Theteacher knows the number of java beans each kids has, now she wants to know themaximum number of java beans she can get from Mconsecutively seated kids. Can you help her?

Input

Thereare multiple test cases. The first line of input is an integer T indicating thenumber of test cases.

For eachtest case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M  N). Here N and M are defined inabove description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicatingnumber of java beans the ith kidhave.

Output

For eachtest case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2

5 2

7 3 1 3 9

6 6

13 28 12 10 20 75

Sample Output

16

158

#include <iostream>

#include <string.h>

using namespace std;

 

int main()

{

   int T;

   cin>>T;

   while(T--)

    {

           int N,M,sum=0,maxs=0;

           cin>>N>>M;

           int *P=new int[N];

           for(int i=0;i<N;i++)

              cin>>P[i];

           for(int k=0;k<N;k++)

           {

                  sum=0;

                  for(int i=k;i<k+M;i++)

               sum=sum+P[i%N];

           if(sum>maxs)

               maxs=sum;

           }

        cout<<maxs<<endl;

    }

       return0;

}

转载于:https://www.cnblogs.com/MisdomTianYa/p/6581819.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值