[poj3349]Snowflake Snow Snowflakes(hash)

Snowflake Snow Snowflakes
Time Limit: 4000MSMemory Limit: 65536K
Total Submissions: 37615Accepted: 9882

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2 1 2 3 4 5 6 4 3 2 1 6 5

Sample Output

Twin snowflakes found.
----------------------------------------------------------------------------------------------------------------
模板题相当水
大概就是把一片雪花的六个参数加一起取模,这样做一个哈希(我觉得叫做“分类”更好)
那么为防止显然的冲突(参数不同和相等或者参数相同但顺序不同)
把hash开成二维的,第二位当做链表处理冲突(术语不会说)
忽然觉得哈希根本没有什么模板,hash的本意就是“杂凑”,所谓的技巧要看情况
还有题目非常有诗意“Snowflake Snow Snowflakes no two snowflakes are alike
代码(熬夜脑子果然不清醒)
 
 
 1 #include<stdio.h>
 2 #include<stdlib.h>
 3 #include< string.h>
 4  const  int mod= 14997;
 5  int hash[mod][ 25][ 6]={{{ 0}}};
 6  int cmp( const  int *a, const  int *b){
 7      int note= 0;
 8      for( int i= 1;i<= 6;i++){
 9         note= 0;
10          if(b[i]==a[ 1]){
11            note= 1;
12             for( int j= 2;j<= 6;j++){
13                 if((i- 1)+j> 6){
14                    if(b[((i- 1)+j)% 6]!=a[j]){note= 0break;}
15                } else  if(b[(i- 1)+j]!=a[j]){note= 0break;}
16            }
17             if(note) return  1;
18            note= 1;
19             for( int j= 2;j<= 6;j++){
20                 if(i+ 1-j< 1){
21                    if(b[i+ 7-j]!=a[j]){note= 0break;}
22                } else  if(b[i-j+ 1]!=a[j]){note= 0break;}
23            }
24             if(note) return  1;
25         }
26     }
27      return  0;
28 }
29  int main(){
30      int n;
31     scanf( " %d ",&n);
32      int read[ 7];
33      for( int i= 1;i<=n;i++){
34         memset(read, 0, sizeof(read));
35          for( int j= 1;j<= 6;j++){
36                 scanf( " %d ",&read[j]);
37                 read[ 0]=(read[ 0]+(read[j]%mod))%mod;
38         }
39          if(hash[read[ 0]][ 0][ 0]== 0){
40            hash[read[ 0]][ 0][ 0]++;
41             for( int k= 1;k<= 6;k++) hash[read[ 0]][ 1][k]=read[k];
42         } else{
43             for( int k= 1;k<=hash[read[ 0]][ 0][ 0];k++){
44                 if(cmp(hash[read[ 0]][k],read)){
45                   printf( " Twin snowflakes found. ");
46                    return  0;
47                }
48            }
49            hash[read[ 0]][ 0][ 0]++;
50             for( int k= 1;k<= 6;k++) hash[read[ 0]][hash[read[ 0]][ 0][ 0]][k]=read[k];
51         }
52     }
53     printf( " No two snowflakes are alike. ");
54      return  0;
55 }

转载于:https://www.cnblogs.com/Pumbit-Legion/p/5565659.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值