HDU 3374 String Problem

http://acm.hdu.edu.cn/showproblem.php?pid=3374

题目

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Input

  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab

Sample Output

1 1 6 1
1 6 1 6
1 3 2 3

题解

设字符串为ABC,转了以后是BCA,若两个相等,则A==B==C,所以若重复,则这个字符串是循环的,用KMP可以求出循环的长度

最小和最大可以用$\mathcal{O}(n)$求出

A A A<B 
A A<B C
A<B C C
A C C C
B C A A
C A A A
C A A A

 若前面的相等,那么后面转了以后会有这样的情况……所以贪心移动下标就好了

当转了以后相等,那么只可能是A==B==C(即ABC和ABC相等),那么说明又转回去了(一个周期转完了)

AC代码

#include<bits/stdc++.h>
#define REP(r,x,y) for(register int r=(x); r<(y); r++)
#define REPE(r,x,y) for(register int r=(x); r<=(y); r++)
#define PERE(r,x,y) for(register int r=(x); r>=(y); r--)
#ifdef sahdsg
#define DBG(...) printf(__VA_ARGS__), fflush(stdout)
#else
#define DBG(...) (void)0
#endif // sahdsg
using namespace std;
int f[2000007];
inline void getf(char *p, int m) {
	int j=f[0]=-1;
	REP(i,0,m) {
		while(j>=0 && p[i]!=p[j]) j=f[j];
		j++;
		f[i+1]=j;
	}
}
char k[2000007];
int l;
inline int getmin() {
	char *a=k, *b=k+1;
	while(1) {
		int i=0;
		while(i<l && a[i]==b[i]) i++;
		if(i==l) break;
		if(a[i]<b[i]) {
			b+=i+1; if(b-k>=l) break;
		} else if(a[i]>b[i]) {
			a+=i+1; if(a-k>=l) break;
		}
		if(a==b) {b++; if(b-k>=l) break;}
	}
	return min(a-k,b-k);
}
inline int getmax() {
	char *a=k, *b=k+1;
	while(1) {
		int i=0;
		while(i<l && a[i]==b[i]) i++;
		if(i==l) break;
		if(a[i]>b[i]) {
			b+=i+1; if(b-k>=l) break;
		} else if(a[i]<b[i]) {
			a+=i+1; if(a-k>=l) break;
		}
		if(a==b) {b++; if(b-k>=l) break;}
	}
	return min(a-k,b-k);
}
int main() {
	while(~scanf("%s", k)) {
		l=strlen(k);
		memcpy(k+l,k,l);
		k[l+l]=0;
		getf(k,l);
		int x=l-f[l], y=1;
		if(l%x==0) {
			y=l/x;
		}
		int m=getmin(), M=getmax();
		printf("%d %d %d %d\n", m+1, y, M+1, y);
	}
}

 

转载于:https://www.cnblogs.com/sahdsg/p/10901678.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值