【KMP】 hdu3374 String Problem

11 篇文章 0 订阅

String Problem

http://acm.hdu.edu.cn/showproblem.php?pid=3374



Problem Description
Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank 
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
 

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Sample Input
  
  
abcder aaaaaa ababab
 

Sample Output
  
  
1 1 6 1 1 6 1 6 1 3 2 3

最小最大表示法+ KMP

求最小表示和最大表示的开始位置(多个解输出最前面的那个)与表示的次数

最小表示法 http://blog.csdn.net/cclsoft/article/details/5467743


#include<cstdio>
#include<cstring>
using namespace std;
#define min(a,b) ((a)<(b)?(a):(b))
char s[1000005];
int next[1000005];
void get_next()
{
    int i=0,j=-1;
    next[0]=-1;
    for(; s[i];)
        if(j==-1||s[i]==s[j])
        {
            ++i;
            ++j;
            next[i]=j;
        }
        else  j=next[j];
}
int MaxmumRepresentation(int l)//最大表示法
{
    int i=0,j=1,k=0,t;
    for(;i<l&&j<l&&k<l;)
    {
        t=s[(i+k)%l]-s[(j+k)%l];
        if(!t) ++k;
        else
        {
            if(t<0) i=i+k+1;
            else j=j+k+1;
            if(i==j) ++j;
            k=0;
        }
    }
    return min(i,j);
}
int MinmumRepresentation(int l)//最小表示法
{
    int i=0,j=1,k=0,t;
    for(;i<l&&j<l&&k<l;)
    {
        t=s[(i+k)%l]-s[(j+k)%l];
        if(!t) ++k;
        else
        {
            if(t>0) i=i+k+1;
            else j=j+k+1;
            if(i==j) ++j;
            k=0;
        }
    }
    return min(i,j);
}
int main()
{
    for(; ~scanf("%s",s);)
    {
        int len=strlen(s);
        int posmax=MaxmumRepresentation(len);
        int posmin=MinmumRepresentation(len);
        get_next();
        int r=len-next[len];//kmp求循环节长度
        if(len%r==0) r=len/r;
        else         r=1;
        printf("%d %d %d %d\n",posmin+1,r,posmax+1,r);
    }
    return 0;
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值