DFS算法基本结构
void dfs() //参数用来表示状态
{
if(到达终点状态)
{
...//根据题意添加
return;
}
if(越界或者是不合法状态)
return;
if(特殊状态)//剪枝
return ;
for(扩展方式)
{
if(扩展方式所达到状态合法)
{
修改操作;//根据题意来添加
标记;
dfs();
(还原标记);
//是否还原标记根据题意
//如果加上(还原标记)就是 回溯法
}
}
}
n皇后问题
输入 8
输出92
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include<ctype.h>
#include <vector>
#define maxn 1000
using namespace std;
int a[10];
int n;
int tot;
int k;
//n皇后问题 点的坐标(cur,a[cur])
void dfs(int cur)
{
int ok;
if(cur==n) tot++;//递归边界,只要走到这里,所有皇后必然不冲突
else
for(int i=0;i<n;i++)//逐行放置,皇后肯定不会横向攻击,
//只需检查纵向 主斜向 副斜向
{
ok=1;
a[cur]=i;//尝试把第cur行的皇后放在第i列
for(int j=0;j<cur;j++)//检查是否和前面的皇后冲突
if(a[cur]==a[j]||cur-a[cur]==j-a[j]||a[cur]+cur==a[j]+j)
// 纵向||同一主对角线 i-j相等||同一副对角线 i+j相等
{
ok=0;
break;
}
if(ok) dfs(cur+1);
}
}
int main()
{
cin>>n;
tot=0;
dfs(0);
cout<<tot<<endl;
return 0;
}
打印出解的代码:
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=102000;
//八皇后问题
int n;
int ans=0;
int a[maxn];
int s[maxn];
void dfs(int cur){
if(cur==n){
ans++;
int k=0;
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
if(j==a[k]){
cout<<1<<" ";
}
else cout<<0<<" ";
}
cout<<endl;
k++;
}
cout<<endl;
return ;
}
int i;
for(i=0;i<n;i++){
int flag=1;
a[cur]=i;//把第cur行放在第i列
for(int j=0;j<cur;j++){
if(a[cur]==a[j]||a[cur]-cur==a[j]-j||a[cur]+cur==a[j]+j){
flag=0;
break;
}
}
if(flag) {
s[cur]= i;
dfs(cur+1);
s[cur]= -1;
}
}
}
int main(){
for(int i=0;i<n;i++){
s[i]=-1;
}
cin>>n;
dfs(0);
cout<<ans;
return 0;
}
图示讲解:https://www.cnblogs.com/bigmoyan/p/4521683.html
牌型种数
小明被劫持到X赌城,被迫与其他3人玩牌。
一副扑克牌(去掉大小王牌,共52张),均匀发给4个人,每个人13张。
这时,小明脑子里突然冒出一个问题:
如果不考虑花色,只考虑点数,也不考虑自己得到的牌的先后顺序,自己手里能拿到的初始牌型组合一共有多少种呢?
请填写该整数,不要填写任何多余的内容或说明文字。
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include<ctype.h>
#include <vector>
#define maxn 1000
using namespace std;
int ans=0;
void dfs(int idx,int cnt){
//idx 当前的点数
//cnt 手中的牌数
if(idx>13||cnt>13) return;
if(idx==13&&cnt==13)
{ans++;
return;
}
for(int i=0;i<5;i++){
dfs(idx+1,cnt+i);
}
}
int main(){
dfs(0,0);
cout<<ans;
return 0;
}
输出3598180
全球变暖
题目描述
你有一张某海域NxN像素的照片,".“表示海洋、”#"表示陆地,如下所示:
.......
.##....
.##....
....##.
..####.
...###.
.......
其中"上下左右"四个方向上连在一起的一片陆地组成一座岛屿。例如上图就有2座岛屿。
由于全球变暖导致了海面上升,科学家预测未来几十年,岛屿边缘一个像素的范围会被海水淹没。具体来说如果一块陆地像素与海洋相邻(上下左右四个相邻像素中有海洋),它就会被淹没。
例如上图中的海域未来会变成如下样子:
.......
.......
.......
.......
....#..
.......
.......
请你计算:依照科学家的预测,照片中有多少岛屿会被完全淹没。
【输入格式】
第一行包含一个整数N。 (1 <= N <= 1000)
以下N行N列代表一张海域照片。
照片保证第1行、第1列、第N行、第N列的像素都是海洋。
【输出格式】
一个整数表示答案。
**【样例输入】**
7
.......
.##....
.##....
....##.
..####.
...###.
.......
【样例输出】
1
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include<ctype.h>
#include <vector>
using namespace std;
const int N = 1010;
char maze[N][N];
int ans1, ans2;
bool flag;
int n;
int fx[4] = {0, 0, 1, -1};
int fy[4] = {1, -1, 0, 0};
bool check(int x, int y)//check合法的“# ”
{
if (maze[x][y] == '.') return false;
if (x < 0 || x >= n || y < 0 || y >= n) return false;
return true;
}
void dfs(int x, int y)//一次dfs把一个岛屿的全部 #-->*
{
int temp = 0;//temp必须定义在函数内部 否则出错
if (!flag)//没找到满足条件的陆地
{
for (int i = 0; i < 4; i++)//目的是查找有没有陆地周围有四个陆地
{
int tx = x + fx[i];
int ty = y + fy[i];
if (check(tx, ty))
{
temp++;
}
}
}
if (temp == 4)//ans==4代表找到一个不会淹没的陆地
{
ans2++;
flag = true;//找到满足条件的陆地flag设为true
}
maze[x][y] = '*';//将访问过的陆地设成*,防止重复访问
for (int i = 0; i < 4; i++)
{
int tx = x + fx[i];
int ty = y + fy[i];
if (check(tx,ty) && maze[tx][ty] != '*')
{
dfs(tx, ty);
}
}
}//一次dfs就能找到一个连通块,也就是一个岛屿,
//并且把该岛屿的陆地全部设置为'*'
int main()
{
cin >> n;
for (int i = 0; i < n; i++)
{
for (int j = 0; j < n; j++)
{
cin>>maze[i][j];
}
}
for (int i = 0; i < n; i++)
{
for (int j = 0; j < n; j++)
{
if (maze[i][j] == '#')//只有在为陆地的时候才进行搜索
{
ans1++;//dfs几次就得到几个岛屿
dfs(i, j);
flag = false;//记得DFS完一个岛屿后要将flag还原
}
}
}
cout << ans1 - ans2 << endl;
return 0;
}
分配口罩
本题总分:10 分
【问题描述】
某市市长获得了若干批口罩,每一批口罩的数目如下:
(如果你把以下文 字复制到文本文件中,请务必检查复制的内容是否与文档中的一致。
在试题目 录下有一个文件 mask.txt,内容与下面的文本相同)
9090400
8499400
5926800
8547000
4958200
4422600
5751200
4175600
6309600
5865200
6604400
4635000
10663400
8087200
4554000
现在市长要把口罩分配给市内的 2 所医院。
由于物流限制,每一批口罩只 能全部分配给其中一家医院。
市长希望 2 所医院获得的口罩总数之差越小越好。
请你计算这个差最小是多少?
【答案提交】
这是一道结果填空题,你只需要算出结果后提交即可。
本题的结果为一个 整数,在提交答案时只填写这个整数,填写多余的内容将无法得分。
```cpp
答案:
2400
```cpp
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=110;
int num1[15]={
9090400, 8499400, 5926800,
8547000, 4958200, 4422600, 5751200, 4175600, 6309600,
5865200, 6604400, 4635000, 10663400, 8087200, 4554000
};
int ans=10000000,s1,s2;
void dfs(int index,int s1,int s2){
if(index>=15)
{
ans=min(ans,abs(s1-s2));
return;
}
dfs(index+1,s1+num1[index],s2);
dfs(index+1,s1,s2+num1[index]);
}
int main(){
dfs(0,0,0);
cout<<ans;
return 0;
}