Planting Trees(水题)


Planting Trees
Time Limit:1000MS     Memory Limit:131072KB     64bit IO Format:%lld & %llu

Description

Input

Output

Sample Input

6
39 38 9 35 39 20 

Sample Output

42 

Hint

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

int a[100100];

bool cmp(int a, int b) {
	return a > b;
}
int main()
{
	int n;
	cin >> n;
	for(int i = 0; i < n; i++) {
		scanf("%d", &a[i]);
	}
	sort(a, a+n, cmp);
	int max = 0;
	for(int i = 0; i < n; i++) {
		a[i] = a[i] + i + 2;
		if(max < a[i]) max = a[i];
	}
	printf("%d\n", max);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值