Xcode插件失效问题解决办法

为了开发者能更好的开发下一版本或下一代iOS、tvOS、watchOS、OS X,苹果会不断的推送Xcode的版本更新,我们也需要更新我们自己的Xcode版本,来使用Xcode里添加的一些新特性。

然而在升级Xcode的过程中我们也会遇到一些问题,那就是之前明明使用着非常不错的Xcode插件,在更新Xcode之后却不能用了,我也遇到过这些问题,并且在网上搜了一些教程,不过好多都说的不全面,因为我遇到的问题他们并没有遇到,所以,我根据自己遇到的情况以及网上搜索到的一些资料提供如下几种解决办法,讲解不到位之处还请体谅。

1.点击Finder-->应用程序,找到Xcode.app后,右键Xcode,选择显示包内容。



选择Comments-->选中info.plist并双击打开。复制其中DVTPlugInCompatibilityUUID对应的值,如:7FDF5C7A-131F-4ABB-9EDC-8C5F8F0B8A90。


复制:7FDF5C7A-131F-4ABB-9EDC-8C5F8F0B8A90


GIF图演示。


2.找到插件安装的位置。

/Users/用户名/Library/Application Support/Developer/Shared/Xcode/Plug-ins


选择失效的插件包,右键显示包内容。


选择Comments,双击info.plist


向DVTPlugInCompatibilityUUIDs中添加之前在Xcode中拿到的UUID。


GIF图演示。


3.完全退出Xcode,然后再重新打开Xcode,选择Load Bundle。


如果不出意外的话,那么经过上面的设置之后原来的插件就又能用了。但是有时经过上的设置插件还是没反应,如果按照上面的这些步骤还不行的话。就把原来的插件删掉,然后到GitHub上下载该插件的旧版本,重复上面的步骤。多尝试几个旧的版本,一个一个的试,就能找到可以使用的。

一个插件的的旧版本在这个地方。

选择Commits。


然后就可以看到该插件之前的各个版本,从上至下从新至旧。


选择一个旧版本,点击进去。选择Browse files


下载需要的该插件的旧版本。


GIF图演示。


阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/bao_libra/article/details/51314260
文章标签: Xcode 插件
个人分类: iOS开发
想对作者说点什么? 我来说一句

Xcode插件管理工具

2015年11月27日 251KB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭