HDU 1695 GCD(莫比乌斯反演入门)

GCD

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15624    Accepted Submission(s): 6013


 

Problem Description

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

 

 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

 

 

Output

For each test case, print the number of choices. Use the format in the example.

 

 

Sample Input

 

2 1 3 1 5 1 1 11014 1 14409 9

 

 

Sample Output

 
Case 1: 9 Case 2: 736427

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).

 

 

Source

2008 “Sunline Cup” National Invitational Contest

 

 

Recommend

wangye   |   We have carefully selected several similar problems for you:  1689 1690 1693 1691 1692 

 

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e5+5;
int a,b,c,d,k,kase;
long long ans1,ans2;
int prime[maxn],vis[maxn],mu[maxn];
void init()
{
    int n=maxn,cnt=0;
    memset(prime,0,sizeof(prime));
    memset(vis,0,sizeof(vis));
    memset(mu,0,sizeof(mu));
    mu[1]=1;
    for(int i=2;i<=n;i++)
    {
        if(!vis[i])
        {
            prime[cnt++]=i;
            mu[i]=-1;
        }
        for(int j=0;j<cnt&&i*prime[j]<n;j++)
        {
            vis[i*prime[j]]=1;
            if(i%prime[j]) mu[i*prime[j]]=-mu[i];
            else
            {
                mu[i*prime[j]]=0;
                break;
            }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    init();
    kase=0;
    while(t--)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if(!k)
        {
            printf("Case %d: 0\n",++kase);
            continue;
        }
        b/=k,d/=k;
        if(b>d) swap(b,d);
        ans1=ans2=0;
        for(int i=1;i<=b;i++)
        {
            ans1+=1LL*mu[i]*(b/i)*(d/i);
            ans2+=1LL*mu[i]*(b/i)*(b/i);
        }
        printf("Case %d: %lld\n",++kase,ans1-ans2/2);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值