hdu 1695 gcd(莫比乌斯反演)

gcd (莫比乌斯反演)

题目

Given 5 integers: a, b, c, d, k, you’re to find x in a…b, y in c…d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you’re only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.
Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.
Output
For each test case, print the number of choices. Use the format in the example.
Sample Input
2
1 3 1 5 1
1 11014 1 14409 9
Sample Output
Case 1: 9
Case 2: 736427

题目大意

从(a,b)和(c,d)各取一个数,使得他们的gcd为k,这样的数有几组,注意a,b和b,a为同样的一组。

题目分析

很容易想到gcd(x,y)==k同等与gcd(x/k,y/k)==1,这样子题目又化简成了熟悉的样子,那么我们又可以利用莫比乌斯反演这次利用的还是第二个样式
在这里插入图片描述
我们可以定义g(n)为n|gcd(x,y),也就是n是gcd(x,y)的约数的数量,那么很容易得到g(n) = sigma{ n|d, f(d) },,应用莫比乌斯反演我们可以得到f(n) = sigma{ n|d, mu(d/n) * g(d) },那么所求的f(1)就是sigma{n|1,mu(d)*g(d)};问题来到g(d)怎么求,这个很简单,和上面一题一模一样,就是他的倍数,那么g(d)=(x/d)*(y/d);(x,y为2个数的上限,题目的上限等于b/k,d/k);
到这里题目已经差不多解决了,还剩下一个问题,怎么去重复,很简单,想要重复实际上就是要这个数2边都要有,那么才可以左边拿一次的时候右边也能拿一次,那么实际上就是把(x,y)的上限变低,变成2个数比较小的那个数,然后除以2就是重复的数量了。

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=1000000+5;
long long mo[maxn], vis[maxn], prime[maxn];
void init () {
	mo[1] = 1;
	memset(vis, 0,sizeof(vis));
	int len = 0;
	for (int i = 2; i < maxn; ++i) {
		if (!vis[i]) {
			prime[len++] = i;
			mo[i] = -1;
		}
		for (int j = 0; j < len && (long long)prime[j] * i < maxn; ++j) {
			vis[ i * prime[j] ] = 1;
			if (i % prime[j] == 0) {
				mo[ i * prime[j] ] = 0;
				break;
			}
			mo[ i * prime[j] ] = -mo[i];
		}
	}
	// for (int i = 2; i < maxn; ++i) mo[i] += mo[i-1];
}
int main()
{
	int a;
	int x,x1,y,y1,z;
	scanf("%d",&a);
	init();
	for(int i=0;i<a;i++)
	{
		scanf("%d%d%d%d%d",&x,&x1,&y,&y1,&z);
		long long sum=0,sum2=0;
		if(z==0)
		{
			printf("Case %d: 0\n",i+1);
			continue;
		}
		x1=x1/z;
		y1=y1/z;
		for(int k=1;k<=min(x1,y1);k++)
		{
			sum+=(mo[k]*(x1/k)*(y1/k));
		}
		for(int k=1;k<=min(x1,y1);k++)
		{
			sum2+=(mo[k]*(min(x1,y1)/k)*(min(x1,y1)/k));
		}
		printf("Case %d: %lld\n",i+1,sum-sum2/2);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值