ZOJ 3469 Food Delivery(区间dp)

Food Delivery


Time Limit: 2 Seconds      Memory Limit: 65536 KB


When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the Npeople, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

 

Sample Output

55

题意:一个外卖员送n份外卖,顾客每多等一分钟不开心值就会增加v,要求不开心值最小。

思路:餐馆的位置在x,顾客的位置散落在附近,左右来回送外卖是最省时的。那么dp[i][j][0]表示区间[i,j]内最小值,并且送完后外卖员的位置在左端,也就是i。dp[i][j][1]表示区间[i,j]内最小是,并且送外后外卖员的位置在右端也就是j。

那么状态转移方程就是如代码所示的四种情况,其中temp是指区间[i,j]以外所有顾客一分钟会增加不开心值的和。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1005;
const int inf=0x3f3f3f3f;
int n,v,x,dp[maxn][maxn][2],sum[maxn];
struct node
{
    int x,v;
    bool operator<(const node &a)const
    {
        return x<a.x;
    }
}a[maxn];
int main()
{
    while(scanf("%d%d%d",&n,&v,&x)!=EOF)
    {
        
    for(int i=1;i<=n;i++)
        scanf("%d%d",&a[i].x,&a[i].v);
    n++;
    a[n].x=x;
    a[n].v=0;
    sort(a+1,a+1+n);
    sum[0]=0;
    int pos;
    for(int i=1;i<=n;i++)
    {
        sum[i]=sum[i-1]+a[i].v;
    }
    for(int i=1;i<=n;i++)
    {
        if(a[i].x==x)
        {
            pos=i;
            break;
        }
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            dp[i][j][1]=inf;
            dp[i][j][0]=inf;
        }
    }
    dp[pos][pos][0]=dp[pos][pos][1]=0;
    for(int i=pos;i>=1;i--)
    {
        for(int j=pos;j<=n;j++)
        {
            if(i==j) continue;
            int x=sum[i-1]-sum[0];
            int y=sum[n]-sum[j];
            int temp=x+y;
            dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(a[i+1].x-a[i].x)*(temp+a[i].v));//从上一个区间的左端转移到本区间左端
            dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(a[j].x-a[i].x)*(temp+a[i].v));//从上一个区间右端转移到本区间左端
            dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(a[j].x-a[i].x)*(temp+a[j].v));//从上一个区间左端转移到本区间右端
            dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(a[j].x-a[j-1].x)*(temp+a[j].v));//从上一个区间右端转移到本区间右端
        }
    }
    printf("%d\n",min(dp[1][n][0],dp[1][n][1])*v);
    }
    return 0;
}

                                

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值