2018 南京网络邀请赛 E. AC Challenge

Dlsj is competing in a contest with n (0 < n \le 20)n(0<n≤20) problems. And he knows the answer of all of these problems.

However, he can submit ii-th problem if and only if he has submitted (and passed, of course) s_isi​ problems, the p_{i, 1}pi,1​-th, p_{i, 2}pi,2​-th, ......, p_{i, s_i}pi,si​​-th problem before.(0 < p_{i, j} \le n,0 < j \le s_i,0 < i \le n)(0<pi,j​≤n,0<j≤si​,0<i≤n) After the submit of a problem, he has to wait for one minute, or cooling down time to submit another problem. As soon as the cooling down phase ended, he will submit his solution (and get "Accepted" of course) for the next problem he selected to solve or he will say that the contest is too easy and leave the arena.

"I wonder if I can leave the contest arena when the problems are too easy for me."
"No problem."
—— CCF NOI Problem set

If he submits and passes the ii-th problem on tt-th minute(or the tt-th problem he solve is problem ii), he can get t \times a_i + b_it×ai​+bi​ points. (|a_i|, |b_i| \le 10^9)(∣ai​∣,∣bi​∣≤109).

Your task is to calculate the maximum number of points he can get in the contest.

Input

The first line of input contains an integer, nn, which is the number of problems.

Then follows nn lines, the ii-th line contains s_i + 3si​+3 integers, a_i,b_i,s_i,p_1,p_2,...,p_{s_i}ai​,bi​,si​,p1​,p2​,...,psi​​as described in the description above.

Output

Output one line with one integer, the maximum number of points he can get in the contest.

Hint

In the first sample.

On the first minute, Dlsj submitted the first problem, and get 1 \times 5 + 6 = 111×5+6=11 points.

On the second minute, Dlsj submitted the second problem, and get 2 \times 4 + 5 = 132×4+5=13 points.

On the third minute, Dlsj submitted the third problem, and get 3 \times 3 + 4 = 133×3+4=13 points.

On the forth minute, Dlsj submitted the forth problem, and get 4 \times 2 + 3 = 114×2+3=11 points.

On the fifth minute, Dlsj submitted the fifth problem, and get 5 \times 1 + 2 = 75×1+2=7 points.

So he can get 11+13+13+11+7=5511+13+13+11+7=55 points in total.

In the second sample, you should note that he doesn't have to solve all the problems.

样例输入1复制

5
5 6 0
4 5 1 1
3 4 1 2
2 3 1 3
1 2 1 4

样例输出1复制

55

样例输入2复制

1
-100 0 0

样例输出2复制

0

题目来源

ACM-ICPC 2018 南京赛区网络预赛

题意:A一道题有前提条件是A掉另外一些给定的题,每一道题有属性a和b,在t时刻A掉一道题的得分是a*t+b,求最大得分。

思路:题数小于20,考虑状压dp,AC一道题的条件就是状态转移的条件。用二进制数来表示答题情况,1代表已经AC,那么首先对于每一道题,用二进制数来代表要A掉它的条件,然后dp[i]代表i这个条件的最大得分,那么转移方程就是dp[i]=max(dp[i^(1<<k)]+a*num+b)(0<k<n),条件是状态i的从右往左第k位0也就是第k题还没有AC,同时状态i满足第k题的前置条件。

#include<bits/stdc++.h>
using namespace std;
const int N = 20 + 5;
typedef long long ll;
struct A {
    ll a, b;
    int s;
} p[N];
ll dp[(1<<20) + 5];
int main() {
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; ++ i) {
        scanf("%lld%lld", &p[i].a, &p[i].b);
        p[i].s = 0; int k;
        scanf("%d", &k);
        for(int j = 0; j < k; ++ j) {
            int pre; scanf("%d", &pre);
            p[i].s |= (1 << pre-1);
        }
    }
    ll ans = 0;
    memset(dp, -1, sizeof(dp));
    dp[0] = 0;
    for(int s = 1; s < (1 << n); ++ s) {
        int num = 0;
        for(int i = 0; i < n; ++ i) if(s & (1 << i))
            num ++;
        for(int i = 0; i < n; ++ i) {
            if((s & (1 << i)) && (s & (p[i].s)) == p[i].s && dp[s ^ (1 << i)] != -1) {
                dp[s] = max(dp[s], dp[s ^ (1 << i)] + p[i].a * num + p[i].b);
            }
        }
        ans = max(ans, dp[s]);
    }
    printf("%lld\n", ans);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值