HDU-1796 How many integers can you find

原题点此

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10539    Accepted Submission(s): 3142

 

Problem Description

  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.

 

Input

  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.

 

Output

  For each case, output the number.

 

Sample Input

12 2 
2 3

Sample Output

7

题意:即找出小于n,且能被集合m中的任意一个数整除的所有整数。

思路:(容斥原理),先求出集合m中每一个元素的所对应的次数,再减去重复部分。

即(一张从别处抠来的图)

参考代码:

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;

typedef long long ll;
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
int main()
{
    //freopen("in.txt","r",stdin);
//    freopen("out.txt","w",stdout);
    ll n,m,summ;
    int a[15];
    while(~scanf("%lld%lld",&n,&m))
    {
        int h=0,x;
        n=n-1;
        for(int i=0;i<m;i++)//将除0外的数存入数组
            {
                scanf("%d",&x);
                if(x!=0)
                    a[h++]=x;
            }
        m=h;
        summ=0;//符合条件的整数个数
//每一个i都代表着一种子集的情况
        for(int i=1;i<(1<<m);i++)//(1<<m)即2^m,
        {
            int cnt=0,k=1;//cnt计数,k为每一次的最小公倍数
//此处控制子集的元素,每一个j都代表一个元素
            for(int j=0;j<m;j++)
                if(i&(1<<j))// 2^j
            {
                cnt++;
                k=a[j]/gcd(a[j],k)*k;
            }
            if(cnt&1)//判断cnt的奇偶
                summ+=n/k;
            else
                summ-=n/k;
        }
        printf("%lld\n",summ);
    }
    return 0;
}

若看着有点绕,可以自己拿一组样例走一遍,可以更加深刻的体会容斥原理及某些语句的妙处。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值