poj3278 Catch That Cow BFS

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Example Input
5 17

Example Output

4

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    int data;
    int step;
}ST;
ST a[500055], t;//数组模拟队列
int vis[500055];
int head, last;//标记首,和尾
void bfs(int n, int k)//广度优先搜索
{
    if(n == k)
    {
        printf("%d\n", a[head].step);//满足条件输出
        return ;//别忘了
    }
    t = a[head++];
    int i, j;
    for(i = 0; i < 3; i++)//下一步分为三种情况
    {
        if(i == 0 && !vis[t.data - 1] && t.data >= 1)//防止越界
        {
            a[last].data = t.data - 1;
            a[last++].step = t.step + 1;
            vis[t.data - 1] = 1;
        }
        else if(i == 1 && !vis[t.data + 1] && t.data <= k)//防止越走越远没意义
        {
            a[last].data = t.data + 1;
            a[last++].step = t.step + 1;
            vis[t.data + 1] = 1;
        }
        else if(i == 2 && !vis[t.data * 2] && t.data <= k)//防止越走越远没意义
        {
            a[last].data = t.data * 2;
            a[last++].step = t.step + 1;
            vis[t.data * 2] = 1;
        }
    }
    bfs(a[head].data, k);
}
int main()
{
    int n, k;
    while(~scanf("%d %d", &n, &k))
    {
        memset(vis, 0, sizeof(vis));
        head = last = 0;
        a[last].step = 0;
        a[last++].data = n;
        vis[n] = 1;
        bfs(a[head].data, k);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值