http://poj.org/problem?id=3278
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题目大意:位置x可通过一步操作到达x+1、x-1、2*x,给定起始位置和终止位置,问至少要多少次操作。
思路:bfs
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn=1e5+2;
int n,k;
int cnt[100005];
int vis[100005];
void bfs()
{
queue<int> q;
q.push(n);
int cur,nxt;
vis[n]=1;
cnt[n]=0;
while(!q.empty())
{
cur=q.front();
q.pop();
if(cur==k)
return ;
for(int i=0;i<3;i++)
{
if(i==0)
nxt=cur+1;
else if(i==1)
nxt=cur-1;
else if(i==2)
nxt=2*cur;
if(nxt<=0||nxt>maxn||vis[nxt])
continue;
vis[nxt]=1;
q.push(nxt);
cnt[nxt]=cnt[cur]+1;
}
}
}
int main()
{
scanf("%d %d",&n,&k);
if(k<=n)
{
printf("%d\n",n-k);
return 0;
}
bfs();
printf("%d\n",cnt[k]);
return 0;
}