Trees on the level 题解 二叉树的层序遍历 二叉树的删除 二叉树的结点插入

Trees on the level

题面

Background

Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines’ CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem

Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L’s and R’s where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once.

The Input

The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output

For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string "not complete’’ should be printed.

Sample Input

(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()

Sample Output

5 4 8 11 13 4 7 2 1
not complete

题目链接

HDU——传送门

代码

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;

struct node
{
    int val;
    node *lc;
    node *rc;
};

void delete_tree(node *p)
{
    if (p != NULL)
    {
        delete_tree(p->lc);
        delete_tree(p->rc);
    }
    delete p;
}

node *insert(node *p, int val, const char *point_str)
{
    if (p == 0)
        p = new node({0, 0, 0});
    switch (*point_str)
    {
    case ')':
        p->val = (p->val == 0) ? val : -1;
        break;
    case 'L':
        p->lc = insert(p->lc, val, point_str + 1);
        break;
    case 'R':
        p->rc = insert(p->rc, val, point_str + 1);
        break;
    }
    return p;
}

int main()
{
    node *root = NULL;
    string str;

    while (cin >> str)
    {
        const char *point_str = str.c_str(); // 读入的字符串上的指针
        // 如果第二个字符不是右括号,则继续输入
        if (point_str[1] != ')')
        {
            int val = 0;
            for (; isdigit(*++point_str); val = val * 10 + *point_str - '0')
                ;
            root = insert(root, val, ++point_str); // 插入该节点
            continue;
        }
        list<node *> level(1, root);
        stringstream res;
        // 层序遍历
        for (auto i = level.begin(); !level.empty(); i = (i == level.end() ? level.begin() : i))
        {
            node *cur_node = *i;
            i = level.erase(i);
            if (cur_node == 0)
                continue;
            if (cur_node->val <= 0) // 返回错误
            {
                level.clear();
                res.str("");
                break;
            }
            res << cur_node->val << ' ';
            i = level.insert(i, cur_node->lc);
            ++i;
            i = level.insert(i, cur_node->rc);
            ++i;
        }
        delete_tree(root); // 删除旧树
        root = 0;
        str = res.str();

        if (str.empty())
            str = "not complete";
        else
            str.erase(str.end() - 1);
        cout << str << endl;
    }
    return 0;
}
  • 26
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值