A1058 A+B in Hogwarts [进制转换]

If you are a fan of Harry Potter, you would know the world of magic has its own currency system — as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

题目大意:17个Sickle对换一个Galleon,29个Knut对换一个Sickle。根据Galleon.Sickle.Knut的方式相加A和B
分析:像相加算术一样从后往前按位相加,处理好进位~

#include<iostream>
using namespace std;
int main()
{
	int n1, n2, n3, n4, n5, n6, n7, n8, n9;
	scanf("%d.%d.%d", &n1, &n2, &n3);
	scanf("%d.%d.%d", &n4, &n5, &n6);
	n9 = (n3 + n6) % 29;
	int carry1=(n3 + n6) / 29;
	n8 = (n2 + n5 + carry1) % 17;
	int carry2 = (n2 + n5 + carry1) / 17;
	n7 = carry2 + n1 + n4;
	printf("%d.%d.%d", n7, n8, n9);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值