POJ 2362 Square

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 17137 Accepted: 5909

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

 题目大意:
给定一些棍子、  问能否将这些棍子围成一个正方形。   

方法: 
搜索、

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<functional>
#include<cstring>
#include<iostream>
using namespace std;

//int a[] = {10,6,13,5,2,6,11,8,3};
//int a[] = {5,2,3,1,4,2,3};
int a[22];

int n;
int used[22];
int edge;
bool solve(int idx,int left,int nth);
bool find(int nth)
{
    int i;
    for( i=0;i<n && used[i];i++) ;
    
    used[i] = nth;
    bool ret =  solve(i+1,edge-a[i],nth);
    used[i] = 0;
    return ret;
}

bool solve(int idx,int left,int nth)
{
    if(left == 0){
        if(nth == 4)  return true;
        else    return find(nth+1);
    }
    else{
        while(idx<n){
            if( !used[idx] && a[idx] <= left ){
                used[idx] = nth;
                if(solve(idx+1,left-a[idx],nth))
                    return true;;
                used[idx] = 0;
            }
            idx ++;
        }
        return false;
    }
}


int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        
        int sum = 0;
        int mx = 0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            sum += a[i];
            if( mx<a[i] )  mx=a[i];
        }
        edge = sum>>2;
        if( (sum & 3) || mx > edge ){
            puts("no");
            continue;
        }
        
        sort(a,a+n,greater<int>());
        
        memset(used,0,sizeof(used));
        if(find(1))  puts("yes");
        else         puts("no");
    }
    //system("pause");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值