Palindromic Squares (USACO)

原题地址

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself.

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696

//这个是我的代码,USACO的题目都比较有技巧性
/*
ID : liuming9
LANG : C++
TASK: palsquare
*/
#include <cstdio>
#include <algorithm>
using namespace std;

int n, size;
char s[100], str[10];
void palsquare(int a){
	int r;
	int x = a * a;
	size =  0;
	//把平方转化为n进制
	while(x){
		r = x % n;
		x /= n;
		if(0 <= r && r <= 9)
			s[size++] = r + '0';
		else
			s[size++] = r + 'A' - 10;
	}
	s[size] = 0;
	for(int i = 0; i < size / 2; i++)
		if(s[i] != s[size - 1 - i])
			return;
	size = 0;
	//把原数字转化为n进制
	while(a){
		r = a % n;
		a /= n;
		if(0 <= r && r <= 9)
			str[size++] = r + '0';
		else
			str[size++] = r + 'A' - 10;
	}
	str[size] = 0;
	//把原数字转化的n进制逆置
	for(int i = 0; i < size / 2; i++)
		swap(str[i], str[size - i - 1]);
	printf("%s %s\n", str, s);
}

int main(){
	freopen("palsquare.in", "r", stdin);
	freopen("palsquare.out", "w", stdout);
	scanf("%d", &n);
	for(int i = 1; i <= 300; i++){
		palsquare(i);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值