Dual Palindromes USACO

原题地址

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28

/*
ID : liuming9
LANG : C++
TASK: dualpal
*/
#include <cstdio>
int N, S, size, cou;
char st[20];
//判断x转化为bas进制的是不是palindromic
bool palindromic(int bas, int x){
	size = 0;
	int r;
	while(x){
		r = x % bas;
		x /= bas;
		st[size++] = r >= 0 && r <= 9 ? r + '0' : r + 'A' - 10;
	}
	st[size] = 0;
	for(int i = 0; i < size / 2; i++)
		if(st[i] != st[size - 1 - i])
			return false;
	return true;
}

int main(){
	freopen("dualpal.in", "r", stdin);
	freopen("dualpal.out", "w", stdout);
	scanf("%d%d", &N, &S);
	for(int i = S + 1; N > 0; i++){
		cou = 0;
		for(int j = 2; j <= 10; j++){
			if(palindromic(j, i))
				cou++;
		}
		//如果i转化为2-10进制时,是palindromic的个数大于等于2
		if(cou >= 2){
			printf("%d\n", i);
			N--;
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值