Barn Repair USACO

It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:M, S, and C (space separated)
Lines 2-C+1:Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.] 

/*
ID : liuming9
LANG : C++
TASK : barn1
*/
/*
*/
#include <cstdio>
#include <algorithm>
using namespace std;

int list[51];
bool cmp(int a, int b){
	return b < a;
}

int main(){
	freopen("barn1.in", "r", stdin);
	freopen("barn1.out", "w", stdout);
	int M, S, C, a, b, t = 0;
	scanf("%d%d%d", &M, &S, &C);
	for(int i = 1; i <= C; i++)
		scanf("%d", &list[i]);
	//如果可以用的board数比stall blocks还小.那么最短需要board长度为C
	if(C <= M){
		printf("%d\n", C);
		return 0;
	}
	sort(list + 1, list + C + 1);
	a = list[1];
	b = list[C];
	for(int i = 1; i <= C - 1; i++)
		list[i] = list[i + 1] - list[i] - 1;
	sort(list + 1, list + C, cmp);
	for(int i = 1; i <= M - 1 && i <= C; i++)
		t += list[i];
	printf("%d\n", b + 1 - a - t);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值