图论 || Silver Cow Party(单向边来回最短路径)

8 篇文章 0 订阅

I - Silver Cow Party

 

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

 

给出n个点和m条边,以及一个点x,1-n点的牛都通过最短的路径到x点去,然后再从x点通过最短路径回去,求用了最多时间的牛用的时间

用dij可以求出从起点x到其他点的最短路径

求到x的最短路径,理论上以其他点为起点执行dij也能求出其他的每个点到x的最短路径,但是耗时,不用那么麻烦

只要同时建个正向图和反向图就行

把边都反向插入建反向图,求s到其他点的最短路径相当与正向图中求其他点到s的最短路径

如果用矩阵存储图,那么矩阵转置

 

#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<fstream>
#include<math.h>
#include<stack>
#include<queue>
#include<bitset>
#include<utility>
#include<set>
#include<map>
#include<sstream>
#define INF 0x7f7f7f7f
using namespace std;
typedef long long ll;
const double eps=0.0000000000001;
const ll mod=1e18;
const int N=1005;
int n,m;
int x;
struct P{
	int v;
	int w;
	bool friend operator<(P a,P b){
		return a.w>b.w;
	}
};
struct Edge{
	int y;
	int nt;
	int w;	
};
int he[N];
int hg[N];
Edge e[N*N];
Edge g[N*N];
int w[N];
int ans[N];
void add(int i,int x,int y,int w,Edge*a,int *b){
	a[i].y=y;
	a[i].w=w;
	a[i].nt=b[x];
	b[x]=i;
}
void dij(int s,Edge*a,int*h){
	memset(w,127,sizeof(w));
	priority_queue<P> q;
	P sp;
	sp.v=s;
	sp.w=0;
	w[s]=0;
	q.push(sp);
	while(!q.empty()){
		P x=q.top();
		q.pop();
		for(int i=h[x.v];i!=-1;i=a[i].nt){
			if(w[x.v]+a[i].w<w[a[i].y]){
				w[a[i].y]=w[x.v]+a[i].w;
				P b;
				b.v=a[i].y;
				b.w=w[b.v];
				q.push(b);
			}
		}
	}
	for(int i=1;i<=n;i++){
		ans[i]+=w[i];
	}
}
int main(){
	while(~scanf("%d%d%d",&n,&m,&x)){
		int xx,yy,tw;
		memset(he,-1,sizeof(he));
		memset(hg,-1,sizeof(hg));
		int k=0;
		for(int i=0;i<m;i++){
			scanf("%d%d%d",&xx,&yy,&tw);
			add(k,xx,yy,tw,e,he);
			add(k,yy,xx,tw,g,hg);
			k++;
		}
		memset(ans,0,sizeof(ans));
		dij(x,e,he);
		dij(x,g,hg);
		int fans=0;
		for(int i=1;i<=n;i++){
			fans=max(fans,ans[i]);
		}
		printf("%d\n",fans);
	}
		
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bekote

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值