图论 || 次短路

Roadblocks

 POJ - 3255 

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 
Lines 2.. R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

 

r条边,n个点的无向图,求从1到n的次短路

 

用数组zd和cd分别维护最短路和次短路,cd[t]表示从s到t的次短路,最短路同理

用spfa思想,通过松弛操作更新最短路和次短路

若点x和y之间有边e,cd[y]可能等于zd[x]+e.w或者cd[x]+e.w,判断这两个值是否比当前最短路的值大,比当前的次短路的值小,如果是就更新次短路的值

#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<fstream>
#include<math.h>
#include<stack>
#include<queue>
#include<bitset>
#include<utility>
#include<set>
#include<map>
#include<sstream>
#define INF 0x7f7f7f7f
using namespace std;
typedef long long ll;
const double eps=0.0000000000001;
const ll mod=1e18;
const int N=5005;
int n;
struct Edge{
	int y;
	int w;
};
vector<Edge> g[N];
bool f[N];
ll zd[N];
ll cd[N];
void spfa(int s,int t){
	memset(zd,127,sizeof(zd));
	memset(cd,127,sizeof(cd));	
	memset(f,0,sizeof(f));
	queue<int> q;
	zd[s]=0;
	cd[s]=INF;
	f[s]=1;
	q.push(s);
	while(!q.empty()){
		int x=q.front();
		q.pop();
		f[x]=0;
		for(int i=0;i<g[x].size();i++){
			Edge e=g[x][i];
			if(zd[x]+e.w<zd[e.y]){
				cd[e.y]=zd[e.y];
				//由于zd[e.y]中存放最短路的值,肯定会比cd[e.y]小
				//当zd[x]+e.w的值小于zd[e.y],那么这个值就是新的最短路,而旧的最短路的值就是次短路 
				zd[e.y]=zd[x]+e.w;				
				if(f[e.y]==0){
					f[e.y]=1;
					q.push(e.y);
				}
			}
			else if(zd[x]+e.w>zd[e.y]){
				//可能zd[x]+e.w的值就是最短路的值,不能用来更新次短路,所以不更新 
				if(zd[x]+e.w<cd[e.y]){
					cd[e.y]=zd[x]+e.w;
					if(f[e.y]==0){
						f[e.y]=1;
						q.push(e.y);
					}
				}
			}
			if(cd[x]+e.w<cd[e.y]&&cd[x]+e.w>zd[e.y]){
				cd[e.y]=cd[x]+e.w;
				if(f[e.y]==0){
					f[e.y]=1;
					q.push(e.y);
				}
			}
			/*
			cout<<x<<" "<<zd[x]<<" "<<cd[x]<<endl;
			cout<<e.y<<" "<<zd[e.y]<<" "<<cd[e.y]<<endl;
			*/
		}		
	}	
}

int main(){
	int r;
	while(~scanf("%d%d",&n,&r)){
		int xx,yy,ww;
		Edge e;
		for(int i=0;i<r;i++){
			scanf("%d%d%d",&xx,&yy,&ww);
			e.y=yy;
			e.w=ww;
			g[xx].push_back(e);
			e.y=xx;
			e.w=ww;
			g[yy].push_back(e);
		}
		spfa(1,n);
		printf("%lld\n",cd[n]);
		for(int i=1;i<=n;i++){
			g[i].clear();
		}
	}
		
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bekote

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值