1016 Parencodings


Parencodings

Time limit: 1 Seconds   Memory limit: 32768K  
Total Submit: 4565   Accepted Submit: 1861  

Let S = s1 s2 … s2n be a well-formed string of parentheses. S can be encoded in two different ways:

  • By an integer sequence P = p1 p2 … pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
  • By an integer sequence W = w1 w2 … wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))
P-sequence 4 5 6666
W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.


Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.


Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.


Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9


Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


Problem Source: Asia 2001, Tehran (Iran)


http://acm.zju.edu.cn/show_problem.php?pid=1016

 

#include  < iostream >
using   namespace  std;

int  parenthese[ 42 ], ps[ 21 ], wps[ 21 ];
int  t, n;

void  solve();

int  main()
{
    cin 
>> t;
    
for ( int i = 1; i <= t; i++ )
    
{
        cin 
>> n;
        
for ( int j = 1; j <= n; j++ )
        
{
            cin 
>> ps[j];
        }


        solve();

        cout 
<< wps[1];
        
for ( int j = 2; j <= n; j++ )
        
{
            cout 
<< " " << wps[j];
        }

        cout 
<< endl;
    }


    
return 0;
}


void  solve()
{
    
int i = 1;
    
int k = 1;
    
int num = 1;
    
int counter = 0;
    ps[
0= 0;

    
while ( i <= n )
    
{
        
for ( int j = 1; j <= ps[i]-ps[i-1]; j++ )
        
{
            parenthese[k] 
= 0;                      //0表示左括号
            k++;
        }


        parenthese[k] 
= 1;                          //1表示右括号
        k++;                                        //-1表示左括号已选
        i++;
    }


    i 
= 1;

    
while ( i <= 2*n )
    
{
        
while ( parenthese[i] == 0 )                //找到右括号
        {
            i
++;
        }


        k 
= i;
        
while ( parenthese[k] == 1 || parenthese[k] == -1 )
        
{
            k
--;
        }


        parenthese[k] 
= -1;

        counter 
= 0;
        
for ( int j = k; j <= i; j++ )
        
{
            
if ( parenthese[j] == 0 || parenthese[j] == -1 )
            
{
                counter
++;
            }

        }


        wps[num] 
= counter;
        num
++;
        i
++;
    }

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值