Max Sequence

Max Sequence
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 17994 Accepted: 7522

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N).  

You should output S.  

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40
#include <iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<queue>
#include<string.h>
#define max(a,b) a>b?a:b

using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        int a[100005],dp[100005];
        int i,j,sum=0,ans,temp=-99999999;
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)//从前往后找区间的最大值
        {
            sum+=a[i];
            if(sum>temp)
                temp=sum;
            dp[i]=temp;
            if(sum<0)
                sum=0;
        }

        sum=0,ans=-99999999,temp=-99999999;
        for(i=n-1;i>0;i--)//倒序查找
        {
            sum+=a[i];
            if(sum>temp)
                temp=sum;
            if(ans<dp[i-1]+temp)
                ans=dp[i-1]+temp;
            if(sum<0)
                sum=0;
        }
        printf("%d\n",ans);
    }

    return 0;
}

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值