poj 2593 Max Sequence

Max Sequence
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 12213 Accepted: 5075

Description

Give you N integers a1, a2 ... aN (|ai| <=1000, 1 <= i <= N).

You should output S.

Input

The input will consist of several test cases. For each test case, one integer N (2 <= N <= 100000) is given in the first line. Second line contains N integers. The input is terminated by a single line with N = 0.

Output

For each test of the input, print a line containing S.

Sample Input

5
-5 9 -5 11 20
0

Sample Output

40
#include <iostream>
using namespace std;
int a[100002],b[100002],c[100002];
int main(){
int i,n,t,sum;
while(scanf("%d",&n) && n){
for(i=0; i<n; i++)
scanf("%d",&a[i]);
for(t=0,sum=INT_MIN,i=0; i<n; i++){
if(t>0)
t+=a[i];
else
t=a[i];
if(t>sum)
sum=b[i]=t;
else
b[i] = sum;
}
for(t=0,sum=INT_MIN,i=n-1; i>=1; i--){
if(t>0)
t+=a[i];
else
t=a[i];
if(t>sum)
sum=c[i]=t;
else
c[i] = sum;
}
for(sum=b[0]+c[1],i=2; i<n-2; i++){
if(b[i]+c[i+1]>sum)
sum=b[i]+c[i+1];
}
printf("%d\n",sum);
}
return 0;
}
 

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258607.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值