zoj3587 Marlon's String(next 数组和kmp)

Marlon's String

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Long long ago, there was a coder named Marlon. One day he picked two string on the street. A problem suddenly crash his brain...

Let Si..j denote the i-th character to the j-th character of string S.

Given two strings S and T. Return the amount of tetrad (a,b,c,d) which satisfy Sa..b + Sc..d = T , ab and cd.

The operator + means concate the two strings into one.

Input

The first line of the data is an integer Tc. Following Tc test cases, each contains two line. The first line is S. The second line is T. The length of S and T are both in range [1,100000]. There are only letters in string S and T.

Output

For each test cases, output a line for the result.

Sample Input
1
aaabbb
ab
Sample Output
9

Author:  CHEN, Weijie
Contest:  ZOJ 10th Anniversary Contest
刚学next数组,不过next数组在好多字符串题目都可以用,个人觉得真的好灵活
解决此题要深刻理解next数组的含义,next[i]表示 i 之前的字符串前面和后面相等的个数(不包括它本身),
比如 aaa,next[0]=next[1]=0,next[2]=1(第一位和最后一位相等,当然前2位也和后2位相等,不过不能包含它本身)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>
#include <vector>
#include <queue>
#include <cstdlib>
#include <string>
#include <set>
#include<stack>
using namespace std;
typedef long long LL;
const int N=100010;
char s[N],t[N];
int next[N];
int cnt1[N],cnt2[N];
void init()
{
    memset(cnt1,0,sizeof(cnt1));
    memset(cnt2,0,sizeof(cnt2));
}
void re(char * p)
{
    int len=strlen(p);
    for(int i=0;i<=(len-1)/2;i++)
        swap(p[i],p[len-1-i]);
}
void getnext()
{
    int n=strlen(t);
    //cout<<"n="<<n<<endl;
    next[0]=next[1]=0;
    int j;
    for(int i=1;i<n;i++)
    {
        j=next[i];
        while(j&&t[j]!=t[i]) j=next[j];
        next[i+1]=t[j]==t[i]?j+1:0;
    }
}
void kmp(char * pp,char *tt,int *cnt)
{
    int lenp=strlen(pp);
    int lent=strlen(tt);
    int j=0;
    for(int i=0;i<lenp;i++)
    {
        while(j&&tt[j]!=pp[i]) j=next[j];
        if(tt[j]==pp[i])
        {
            cnt[j]++;
            j++;


        }
        if(j==lent)
        {
            j=next[j];
        }
    }
    //cout<<cnt1[0]<<cnt1[1]<<cnt1[2]<<endl;
   // cout << "****"<< endl
    for(int i=lent;i>=2;i--)
        if(next[i]!=0){
        cnt[next[i]-1]+=cnt[i-1];
        //cout<<"i="<<i<<endl;
        }


}
LL solve()
{
    //cout<<cnt1[0]<<cnt1[1]<<cnt1[2]<<endl;
   // cout<<cnt1[0]<<cnt2[1]<<cnt2[2]<<endl;
    LL ans=0;
    int m=strlen(t);
    for(int i=0;i<m;i++)
        ans+=(LL)cnt1[i]*cnt2[m-2-i];              // 没强制转换成LL,导致最后检查了2小时,没想到给的样例这么极限
    return ans;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%s",s);
       scanf("%s",t);
       init();
       getnext();
       kmp(s,t,cnt1);
       re(s);
       re(t);
       getnext();
       kmp(s,t,cnt2);
       printf("%lld\n",solve());
    }
    return 0;
}





































评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值