ZOJ 题目3587 Marlon's String(KMP)

Marlon's String

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Long long ago, there was a coder named Marlon. One day he picked two string on the street.A problem suddenly crash his brain...

Let Si..j denote the i-th character to the j-th character of string S.

Given two strings S and T. Return the amount of tetrad (a,b,c,d) which satisfy Sa..b + Sc..d = T , ab and cd.

The operator + means concate the two strings into one.

Input

The first line of the data is an integer Tc.Following Tc test cases, each contains two line. The first line is S. The second line is T.The length of S and T are both in range [1,100000]. There are only letters in string S and T.

Output

For each test cases, output a line for the result.

Sample Input
1
aaabbb
ab
Sample Output
9

题目大意:Return the amount of tetrad (a,b,c,d) which satisfy Sa..b + Sc..d = T , ab and cd.

ac代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[200010],b[200010];
int c1[200010],c2[200010];
int next[200010];
void getnext(char *a)
{
	next[0]=next[1]=0;
	int i;
	int m=strlen(a);
	for(i=1;i<m;i++)
	{
		int j=next[i];
		while(j&&a[i]!=a[j])
			j=next[j];
		next[i+1]=(a[i]==a[j])?j+1:0;
	}
}
void kmp(char *a,char *b,int *c)
{
	getnext(b);
	int j=0,i;
	int n=strlen(a);
	int m=strlen(b);
	for(i=0;i<n;i++)
	{
		while(j&&a[i]!=b[j])
			j=next[j];
		if(a[i]==b[j])
		{
			j++;
			c[j]++;
		}
	}
	for(i=m;i>=0;i--)
		if(next[i])
			c[next[i]]+=c[i];
} 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		scanf("%s%s",a,b);
		int len1=strlen(a);
		int len2=strlen(b);
		kmp(a,b,c1);
		reverse(a,a+len1);
		reverse(b,b+len2);
		kmp(a,b,c2);
		long long ans=0;
		for(i=0;i<len2;i++)
			ans+=(long long)c1[i]*c2[len2-i];
		printf("%lld\n",ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值