HDU-1241 Oil Deposits

HDU-1241 Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the absence of oil, or ‘@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1241

分析

题意:‘@’表示一个油田,如果‘@’周围也有油田的话,则表示这是一个油田的一部分,就是表示为一个大油田,而这道题就是让我们找出有多少个大油田

思路:很明显,这是一道深搜题,从地图的第一个开始搜索,找到一个’@’后,对其周围8个方向进行搜索,如果是油田的话就标记为’*’,直到8个方向都不是’@’,然后使油田数+1就行了,最后输出这个数。

代码
#include <stdio.h>
#include <iostream>
#define N 105
using namespace std;
char chara[N][N];
int n,m;
int xy[8][2]={1,1,1,0,1,-1,0,1,0,-1,-1,0,-1,1,-1,-1};
int place(int a,int b)
{
    if (chara[a][b]=='@'&&a>=0&&a<n&&b>=0&&b<m)
        return 1;
    return 0;
}
void DFS(int a,int b)
{
    if (!place(a,b))
        return;
    for (int i=0;i<8;i++)
    {
        chara[a][b]='*';
        int x=a+xy[i][0];
        int y=b+xy[i][1];
        DFS(x,y);
    }
}
int main()
{
    while (~scanf("%d %d",&n,&m),n!=0&&m!=0)
    {
        int sum=0;
        for (int i=0;i<n;i++)
            for (int j=0;j<m;j++)
                cin>>chara[i][j];
        for (int i=0;i<n;i++)
            for (int j=0;j<m;j++)
                if (chara[i][j]=='@')
                {
                    DFS(i,j);
                    sum++;
                }
        printf("%d\n",sum);
    }
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值