hdu3746 Cyclic Nacklace (kmp------next数组)

 Cyclic Nacklace
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 use MathJax to parse formulas

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task. 

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2: 

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden. 
CC is satisfied with his ideas and ask you for help.
 

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases. 
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input

 
    
3 aaa abca abcde
 

Sample Output

 
    
0 2 5

给出一个串str1,问进行几次操作可以把这个串补成字串str2*n的形式

比如说abca,补全后为abcabc,补了2次,结果为(“abc”)*2


利用next求循环节即可,怎么求可以参考此题

然后用循环节的长度求解差值即可

表达式 : 

                1) ans  = i - next[i]     ///求循环节长度

                2) ans = ans - next[i]%ans   ///(i = 串的长度n)

            对于式子2:

                        因为此时的ans为循环节长度,而next[i]为总串长(其实应该再加上ans才是总串长的但是由于ans是循环节,一个n次循环去掉一个循环节的结果是不变的,所以就不用加了)        next[i]%ans为余下来的长度,比如说abcabcab,此时的ans为abc,next[i]%ans = 2,是最后一组未完成循环节的长度,相减即为要补上的字母数量


注意这道题其实是有点问题的

            1)千万千万别用memset

            2)千万千万别用cin

               不要问为什么,我在vj交了5发又在hdu交了5发才在hdu问题讨论上看见这个坑的

代码如下:

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstdio>
#include <queue>
#include <cstring>
#define For(i,n) for(int i=0;i<n;i++)
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int maxn = 1e6+5;
int x;
char s2[maxn];
int nexta[maxn];
void Find_Next() {
    nexta[0] = -1;
    nexta[1] = 0;
    int cnt = 0;
    int i = 2;
    while(i<=x) {
        if(s2[i-1]==s2[cnt])
            nexta[i++] = ++ cnt;
        else if(cnt>0)
            cnt = nexta[cnt];
        else
            nexta[i++] = 0;
        }
    }

int main() {
    int cnt = 0;
    int ans;
    scanf("%d",&cnt);
    while(cnt--) {

        scanf("%s",&s2);
        x = strlen(s2);
        Find_Next();
        ans = x - nexta[x];
        if(ans!=x&&x%ans==0)
            printf("0\n");
        else
            printf("%d\n",ans-nexta[x]%ans);
        }
    return 0;
    }

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值