A Simple Problem with Integers

A Simple Problem with Integers

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 262144/131072K (Java/Other)
Total Submission(s) : 43   Accepted Submission(s) : 16
Problem Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

 

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

 

Output

You need to answer all Q commands in order. One answer in a line.

 

Sample Input
  
  
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4
 

Sample Output
  
  
4 55 9 15
 

Source
PKU
 

/*区间更新&区间和查询*/
#include<stdio.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 111111
#define LL long long
LL sum[maxn << 2];		//sum[]结点表示区间和
LL add[maxn << 2];		//col[]结点表示区间内每个元素的增量		//这里add需要用long long, 否则WA;
void PushUp(int rt)
{
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}
void build(int l, int r, int rt)
{
	int m;
	add[rt] = 0;
	if (l == r)
	{
		scanf("%lld", &sum[rt]);
		return;
	}
	m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
}
/*PushDown的功能是增量传递*/
void PushDown(int rt, int width)
{
	if (add[rt])
	{
		add[rt << 1] += add[rt];		//!!注意这里传递的是增量!!
		add[rt << 1 | 1] += add[rt];
		sum[rt << 1] += (width - (width >> 1))*add[rt];
		sum[rt << 1 | 1] += (width >> 1)*add[rt];
		add[rt] = 0;		//清除当前结点的标记;
	}
}
/*updata的功能是区间更新*/
void Updata(int L, int R, int data, int l, int r, int rt)
{
	int m;
	if (L <= l&&r <= R)			//lazy法的特色,更新到区间就足够了
	{
		add[rt] += data;
		sum[rt] += (r - l + 1)*data;
		return;
	}
	/*区间[l,r]部分落在[L,R]外*/
	PushDown(rt, r - l + 1);
	m = (l + r) >> 1;
	if (L <= m)
		Updata(L, R, data, lson);
	if (R>m)
		Updata(L, R, data, rson);
	PushUp(rt);
}
LL Query(int L, int R, int l, int r, int rt)
{
	int m;
	if (L <= l&&r <= R)
		return sum[rt];
	PushDown(rt, r - l + 1);
	m = (l + r) >> 1;
	LL ret = 0;
	if (L <= m)
		ret += Query(L, R, lson);
	if (R > m)
		ret += Query(L, R, rson);
	return ret;
}
int main()
{
	int N, Q;
	char op[5];
	int a, b, c;
	//freopen("f:\\input.txt", "r", stdin);
	scanf("%d%d", &N, &Q);
	build(1, N, 1);
	while (Q--)
	{
		scanf("%s", op);
		if (op[0] == 'Q')
		{
			scanf("%d%d", &a, &b);
			printf("%lld\n", Query(a, b, 1, N, 1));
		}
		else
		{
			scanf("%d%d%d", &a, &b, &c);
			Updata(a, b, c, 1, N, 1);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值