kiki's game

kiki's game

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 40000/1000K (Java/Other)
Total Submission(s) : 75   Accepted Submission(s) : 50
Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 

Sample Output
  
  
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
HDU 2007-11 Programming Contest
 

对于P点,N点理解得还不够, 别人说的又不统一,又貌似不正确. 目前自己是这样理解的,也不一定对: 
0.终点是P点
1.N点: 至少有一种方式能做出N→P动作
2.P点: 只能做出P→N动作
对于此题附上一图:
hdu-2147:kikis game - 陈年往事 - 我学acm 的博客
当且仅当m和n同时为基数是kiki一开始才处于P点, 所以...
#include<cstdio>
#include<algorithm>
using namespace std;

int main()
{
	int n, m;
	while (scanf("%d%d", &n, &m) && n != 0)
	{
		printf("%s\n", (m%2==1&&n%2==1) ? "What a pity!" :"Wonderful!" );
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值