(三分法)Light Bulb

5 篇文章 0 订阅
2 篇文章 0 订阅

Light Bulb

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 62   Accepted Submission(s) : 37
Problem Description
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

 

Source
The 6th Zhejiang Provincial Collegiate Programming Contest
 
题目大意:求人落在地上和墙上的影子的最长长度是多少?
分析:分情况:
1.影子全部落在地上.
2.影子部分落在地上,部分落在墙上. 那么三分.

三分法步骤:
1.求出目标函数f的表达式, 求它的二阶导数,判断它是否为凸函数或凹函数.
2.用L,R,mid1,mid2四点将区间分成三段, 每次舍掉三段中离极值点较远的部分再进行三分, 直到mid1和mid2近似相等.

#include<cstdio>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
const double EPS = 1e-8;
double H, h, D;

double f(double x)
{
	return -x + H + D + (h - H)*D / x;
}
double ternary_search(double L, double R)
{
	while (R - L > EPS)
	{
		double mid1 = L + (R-L) / 3;
		double mid2 = R - (R-L) / 3;
		if (f(mid1) < f(mid2))
			L = mid1;
		else
			R = mid2;
	}
	return f((L + R) / 2);
}
int main()
{
	int T;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%lf%lf%lf", &H, &h, &D);
		double ans = h*D / H;
		ans = max(ans, ternary_search((H - h)*D / H, D));
		printf("%.3lf\n", ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值