Light Bulb(三分)

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3203


Light Bulb

Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and Hh >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000


Author:   GUAN, Yao
Source:   The 6th Zhejiang Provincial Collegiate Programming Contest
Submit      Status


 

解析:用三分法求解:

 

  三分法与二分法

1.共同点:

都是用于查找在某一区间上的目标值,通常是最小值,最大值,目标值等

2.不同点:

二分法:使用于单调函数,一般指递增或递减函数类型

三分法:用于凸函数,例如;y=x^2函数类型,用于求极值

以下是模板;

Eps=1e-10;

Double  cale(double x )

{}

二分法查找:

Double  solvedouble  lowdouble  high,double V{

Int mid;

While(low+eps<high)

 {

  Mid=(low+high)/2.0;

If(cale(mid)>V)

High=mid;

Else

Low=mid;

 }

Return low;

}

三分法:

double solve(double l,double r)

{

    double m;

    double mm;

    while(l+ep<r)//注意高精度

    {

        m=(l+r)/2.0;

        mm=(m+r)/2.0;

        if(lenth(m)>lenth(mm))//取最大值(如果取最小值的话则变为(lengthm<length(mm)))

         r=mm;

         else

         l=m;

    }

    return l;

}

 

这里求最大阴影长度,可以根据相似三角形求得

L/x+L=h/H;则有L=(h*x)/(H-h)

分为两种情况:

一,全部投影都在地上:即x+L<=D,则输出长度为L

二,投在了地上和墙上: L1=(D*h-D*H+H*x)/x;//墙上投影(根据相似三角形可得)

则,输出长度为:D-x+L1

#include<string.h>

#include<stdio.h>

#include<math.h>

#include<algorithm>

#include <iostream>

using namespace std;

const double ep=1e-10;

double H,h,D;

double lenth(double x)

{

    double L,L1;

    L=(h*x)/(H-h);//有相似三角形性质得来

    if(x+L<=D)//当只能投影在地上时

     return L;

    L1=(D*h-D*H+H*x)/x;//墙上投影

    return D-x+L1;

}


double solve(double l,double r)

{

    double m;

    double mm;

    while(l+ep<r)//注意高精度

    {

        m=(l+r)/2.0;

        mm=(m+r)/2.0;

        if(lenth(m)>lenth(mm))//取最大值

         r=mm;

         else

         l=m;

    }

    return l;

}

int main()

{

    int T;

    double L;

    scanf("%d",&T);

    while(T--)

    { scanf("%lf%lf%lf",&H,&h,&D);

            L=lenth(solve(0,D));

            printf("%.3lf\n",L);

    }

    return 0;

}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值