【杭电oj5773】The All-purpose Zero

                               The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1592    Accepted Submission(s): 763


Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 

Author
FZU
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5831  5830  5829  5828  5827 
 思路:0的个数加上非0的序列的最长上升子序列的长度,这样就被坑了,还要注意可能某个区间0的个数特别多以致于此区间内的一部分0是用不上的,所以就有了我代码的注释。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
using namespace std;
const int N = 100005;
const int INF = 1<<30;
int a[N],b[N];
int find(int l,int r,int x) {
	while(l<=r) {
		int mid=l+r>>1;
		if(b[mid]<x) l=mid+1;
		else if(b[mid]>x) r=mid-1;
		else {
			l=mid;
			break;
		}
		//printf("---\n");
	}
	return l;
}
int main() {
	int T,p=0,n,t;
	scanf("%d",&T);
	while(T--) {
		int cnt=0,temp=0;
		scanf("%d",&n);
		for(int i=0; i<n; i++) {
			scanf("%d",&t);
			if(!t) temp++;
			else a[cnt++]=t-temp;    //因为此处的马虎,错的我怀疑人生,你看测试的地方辣莫多
									//通过减去之前出现的0的个数确定原序列的升序改变 
			//	printf("%d--\n",cnt);
		}
		if(!cnt) {
			printf("Case #%d: %d\n",++p,temp);
			continue;
		}
		int len=0;
		b[0]=-INF;
		for(int i=0; i<cnt; i++) {
			//	printf("%d--\n",a[i]);
			if(a[i]>b[len])
				b[++len]=a[i];
			else {
				int j=find(1,len,a[i]);
				b[j]=a[i];
			}
			//	printf("%d---\n",len);
		}
		printf("Case #%d: %d\n",++p,len+temp);
	}
	return 0;
}

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=5773


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值