The All-purpose Zero

F - The All-purpose Zero
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.

Input

The first line contains an interger T,denoting the number of the test cases.(T <= 10) 
For each case,the first line contains an interger n,which is the length of the array s. 
The next line contains n intergers separated by a single space, denote each number in S. 

Output

For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.

Sample Input

2
7
2 0 2 1 2 0 5
6
1 2 3 3 0 0

Sample Output

Case #1: 5
Case #2: 5


        
  

Hint

     
     
0可以变成任何数,找到可能的最长的最大递增子序列。很喜欢这道题。 微笑
可以先把0挑出来,并让数组里的每个数都减去自己前面的0的个数,将他消平,然后求最大递增子序列,加上0的个数就好.
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.

#include<stdio.h>//f
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 100010;
const int inf = 99999999;
int a[maxn],f[maxn],b[maxn];
int n,t;

int main(){
	int text = 1;
	scanf("%d",&t);
	while(t--){
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%d",&n);
		for(int i=1; i<=n; i++){
			scanf("%d",&a[i]);	f[i] = inf;
		}
		int o = 0;
		int top = 1;
		for(int i=1; i<=n; i++){
			if(a[i] == 0){
				o++;
			}
			else{
				b[top++] = a[i] - o;
			}
		}
		int ans = 0; 
		for(int i=1; i<=n-o; i++){
			int k = lower_bound(f+1,f+1+n,b[i])-f;
			f[k] = min(f[k],b[i]);
			ans = max(ans,k);
		}
		printf("Case #%d: %d\n",text++,ans+o);
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值