【POJ3461】Oulipo

4 篇文章 0 订阅

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35904 Accepted: 14492

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

[Submit]   [Go Back]   [Status]   [Discuss]

这个是子串匹配,和模板的模式串匹配有一点不同,就那一点next数组值的存储范围包括第lens个,因为你判断玩一个子串后要判断是不是前面有已经重合的部分,就像第二个输入输出样例。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
const int N = 1e6+20;
const int M = 1e5+10;
char p[N],s[M];
int next[M];
int lens,lenp;
void getNext() {
	int j,k;
	next[0]=-1;
	j=0,k=-1;
	while(j!=lens) {
		if(k==-1||s[k]==s[j]) {
			k++;
			j++;
			next[j]=k;
		} else
			k=next[k];
	}
}
int KMPMatch() {
	int i=0,j=0,count=0;
	while(i<lenp) {
		if(j==-1||p[i]==s[j]) {
			i++;
			j++;
		} else
			j=next[j];
		if(j==lens) {
			count++;
			j=next[j];
		}
	}
	return count;
}
int main() {
	int T;
	scanf("%d",&T);
	while(T--) {
		scanf("%s%s",s,p);
		lens=strlen(s);			//加了这两句就能ac,不加直接strlen(s)就超时,我也是醉了 
		lenp=strlen(p);			//不造为啥,以后要规范细节啊,否则容易吃大亏,
								//尽量避免意向不到的错误而导致改都不知道怎么改 
		getNext();
		int ans=KMPMatch();
		printf("%d\n",ans);
	}
	return 0;
}
题目地址:http://poj.org/problem?id=3461





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值